feisty fawn, external ntfs HD via usb 2, mounts but as read-only, how to make it read/write?

Asked by benissimo on 2007-04-08

Hello, I'm a newbie to Ubuntu, so apologies in advance if I'm
overlooking something obvious. I have a Dell Inspiron 1501 with Ubuntu
Feisty Fawn 7.04. Connecting an external HD via usb 2, ubuntu mounts the
drive as read-only as /media/Volume.

Browsing similar issues in the bug tracker, I notice that details are
often supplied by providing the output of the mount command or else by
checking /var/log/messages. So on the off chance this could be useful:

mount:
/dev/sda6 on / type reiserfs (rw,notail)
proc on /proc type proc (rw,noexec,nosuid,nodev)
/sys on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
devshm on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
lrm on /lib/modules/2.6.20-13-generic/volatile type tmpfs (rw)
/dev/sda7 on /home type ext3 (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/sdb1 on /media/Volume type ntfs (rw,nosuid,nodev,umask=222,utf8)

most recent relevant (?) output from /var/log/messages:
Apr 4 22:36:59 bellisnb kernel: [ 4889.004000] usb 6-7: new high speed USB device using ehci_hcd and address 5
Apr 4 22:36:59 bellisnb kernel: [ 4889.136000] usb 6-7: configuration #1 chosen from 1 choice
Apr 4 22:36:59 bellisnb kernel: [ 4889.136000] scsi6 : SCSI emulation for USB Mass Storage devices
Apr 4 22:37:04 bellisnb kernel: [ 4894.136000] scsi 6:0:0:0: Direct-Access SAMSUNG SP2014N 0811 PQ: 0 ANSI: 0
Apr 4 22:37:04 bellisnb kernel: [ 4894.140000] SCSI device sdb: 390721968 512-byte hdwr sectors (200050 MB)
Apr 4 22:37:04 bellisnb kernel: [ 4894.140000] sdb: test WP failed, assume Write Enabled
Apr 4 22:37:04 bellisnb kernel: [ 4894.144000] SCSI device sdb: 390721968 512-byte hdwr sectors (200050 MB)
Apr 4 22:37:04 bellisnb kernel: [ 4894.144000] sdb: test WP failed, assume Write Enabled
Apr 4 22:37:04 bellisnb kernel: [ 4894.144000] sdb: sdb1
Apr 4 22:37:04 bellisnb kernel: [ 4894.152000] sd 6:0:0:0: Attached scsi disk sdb
Apr 4 22:37:04 bellisnb kernel: [ 4894.152000] sd 6:0:0:0: Attached scsi generic sg1 type 0
Apr 4 22:37:43 bellisnb kernel: [ 4933.568000] NTFS volume version 3.1.

Any advice on some work-around to enable mounting the HD r/w would be
greatly appreciated!

p.s. I gather the issue is with the drive being ntfs. I tried installing ntfsmount, fuse, etc. following the advice here http://www.arsgeek.com/?p=585 but no luck.

Thanks,
Ben

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-04-08
Last reply:
2007-04-22

Take a look at the following page about writing to windows partitions.

https://help.ubuntu.com/community/MountingWindowsPartitions

Albrecht Mühlenschulte (a7p) said : #2

Take a look at https://help.ubuntu.com/community/MountingWindowsPartitions?action=show&redirect=NTFSReadWrite
may be this is what you are looking for?

https://wiki.ubuntu.com is generally a good information source.

Happy Easter,
   Albrecht

IkimashoZ (ikimashoz) said : #3

On the page cited above, "https://help.ubuntu.com/community/MountingWindowsPartitions", it says "Ubuntu 7.04 can read and write files on the NTFS drives commonly used by Windows."

This is certainly not the case for me. I recently updated my system from edgy to feisty using the update manager, and I still have read-only access to my USB 2.0 500gb external hd, with only one NTFS partition. I am also unable to unmount it except through the terminal.

Please advise.

Can you help with this problem?

Provide an answer of your own, or ask benissimo for more information if necessary.

To post a message you must log in.