No input recognized in X for Intrepid Beta

Asked by schmoo2x

I have a WinBook GL35 Laptop(Which means Intel Centrino CPU, nVidia Graphics, and Intel Chipset) which i've been happily running Hardy on for quite some time in a dual-boot environment, with Ubuntu being the default of course.
Upon the beta release, I ran update-manager -d to get the distro upgrade, but it appeared to not complete all the way. The upgrade hung at the "ldconfig deferred processing now taking place..." terminal dialogue. After several hours of waiting on it (overnight, actually) I simply shut it down since I needed to take the thing to work. Once every other day, it would remind me that I needed to complete a partial upgrade, which i did. BUT - After the partial upgrade that took place I think on Wednesday(or so) when I rebooted, When X booted into the login screen, the keyboard, external mouse, and Touchpad were all unresponsive. However, Ctrl+Alt+F2 worked, so I tried to search for an update from there. It let me know that there was an xinput upgrade and three others(I forget which), so I grabbed them and instructed apt-get to install them.
After the reboot, there was no aparrent change, except that when I press Ctrl+Alt+F2, it now gives me what looks like the Adventures of ZZT all over again. flashing multicolored ASCII Characters.
Is there any way for me to get this distro upgraded somehow to fix whatever packages are broken? I can't even fathom what packages they would be... I'd hate to have to re-install Ubuntu... :-(

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Sergio Rubio
Last query:
Last reply:
Revision history for this message
schmoo2x (louis-ok-computers) said :

Just to clarify: Once I was in Terminal, every key on the keyboard worked fine, but never did it work back in the X login screen.

Revision history for this message
Sergio Rubio (rubiojr) said :

It happened to me. I upgraded from Hadry to Intrepid.

I fixed it removing (with --purge) all the packages related to xorg and reinstalling them.

Revision history for this message
schmoo2x (louis-ok-computers) said :

That sounds like a good idea, but I can't get to terminal anymore - when I hit CTRL+ALT+F2 (or CTRL+ALT+F1, for that matter) it gives me random multicolored ASCII Characters, many of them flashing.
I suppose I could do this if I somehow was able to boot into a terminal, bypassing X, but I have *no* clue how to do that.

Revision history for this message
Sergio Rubio (rubiojr) said :

Maybe you can boot from the livecd and chroot to the root file system in your harddrive after mounting it.

Revision history for this message
schmoo2x (louis-ok-computers) said :

So I did that in a slightly different way - from the alternate install CD, I booted into the "Repair Broken System" option, and mounted /dev/sda5/ (which is my linux partition) and got into bash as root just fine.
# apt-get purge xorg
# apt-get purge xinput
# apt-get install xinput
# apt-get install xorg
this was, of course, after I checked to see that i had an IP address in ifconfig, but none of this changed anything about how it worked... I imagine I might be able to get some new package lists put doing an apt-get update which could fix it, *BUT* for whatever reason, even though I get an IP address (and the very same laptop works while booted in its windows partition) it's having a hard time resolving anything, much less the ubuntu package list...
so weird.
At least we're at a terminal now though, eh?

Revision history for this message
Sergio Rubio (rubiojr) said :

Ummm, the list of packages I purged was much longer. Basically everything related to Xorg and it's libraries. Then you can install ubuntu-desktop metapkg to get everything working again...

Revision history for this message
Best Sergio Rubio (rubiojr) said :

Linked a possible related bug

Revision history for this message
schmoo2x (louis-ok-computers) said :

Thanks rubiojr, that solved my question.