Xp is Unable to boot.

Asked by shailesh on 2008-09-30

I installed ubuntu on the preinstalled xp sysytem.
When i switch on my computer.
Grub-loader displayed: ubuntu and xp loaded but when i clicked on xp, system restarted.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Jim Hutchinson
Solved:
2008-10-02
Last query:
2008-10-02
Last reply:
2008-10-01
anirbanphys (anirbanphys) said : #1

u hv 2 install again XP on another partition.u've done the wrong job.

Andrew (and471) said : #2

Sorry anirbanphys , unless I misunderstood you, that is not correct.

Could you please boot into Ubuntu, open a terminal and type in

gksudo fdisk -l

(Type in your password in the dialog that pops up)

Then can you please paste the output of that command here.

Best Jim Hutchinson (jphutch) said : #3

Actually, the gksudo command is used for graphical apps. Since fdisk is just a command line app regular sudo would be preferred.

sudo fdisk -l

Andrew (and471) said : #4

No, this way, there is visual feedback of the user entering their password, and as a graphical environment has been assumed as bootable, gksudo is better Jim.

shailesh, just ignore these last two posts, the first one is the to follow.

Jim Hutchinson (jphutch) said : #5

Not to hijack the thread but for clarity sake either command, sudo or gksudo, should work. Strictly speaking, however, gksudo (or gksu) is used to launch graphical apps with root privileges and sudo for command line commands. Fwiw, in my own test, gksudo fdisk -l fails to give the desired output in the terminal.

Shailesh, you are free to try what works for you and I don't think gksudo will cause any problems but in my test it did not produce any output. If you use sudo you will not see anything entered as you type your password - that is normal. For more information on sudo, and it's good to understand this in Ubuntu, see https://help.ubuntu.com/community/RootSudo.

rugby471 - I have never seen anyone suggest using gksudo or gksu for command line commands (as opposed to graphical applications). Before insisting that this is the proper way, please provide some credible evidence for this procedure.

Bhavani Shankar (bhavi) said : #6

I agree with jim here

gksudo is only for graphical applications and fdisk is a CLI

so its

sudo fdisk -l

Regards

Andrew (and471) said : #7

Sorry guys, in my last post, I wasn't insisting that gksudo should always be used.

When you are a new user, it is easy to see visual feedback of when you put in your password, when you don't see this, it can be a bit cinfsing.

Therefore when I do my answers, I say use gksudo instead of sudo, to avoid having to explain all of this. Normally it works, but for fdisk, it doesn't, strangely enough, thanks for correcting me on this Jim.

Right so shailesh, ignore our discusison up above :-) , the correct command is:

sudo fdisk -l

Then type in your password when it asks you too (don't worry you won't see any visual feedback) and paste the output of that command here

shailesh (shaileshagarwal1) said : #8

Thanks Jim Hutchinson, that solved my question.