Drivers for logithech mouse

Asked by Wladston Viana on 2007-04-04

Hello,

I have a logitech laser mouse that is working, but not completely. None of the non-standard buttons work (the page up/page down next to the thumb place, the zoom +/- buttons, and the scroll left/right)

Is there anyway to have those enabled ?

lsusb shows : Bus 001 Device 002: ID 046d:c50e Logitech, Inc. MX-1000 Cordless Mouse Receiver

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Wladston Viana
Solved:
2007-04-07
Last query:
2007-04-07
Last reply:
2007-04-07
trylik (marek-nasionka) said : #1

how many buttons and scrolls does this mouse have?

can you paste here xorg.conf file?

Wladston Viana (wladston) said : #2

One scrol, but it works on the horizontal side too.

So here it goes

Left/Right/Center click (3)
Scrol up/down/left/right (4)
Zoom +/- (2)
Zoom 100% (1)
> and < (2)

TOTAL : 12

xorg.conf paste :
-------------------
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
 FontPath "/usr/share/fonts/X11/misc"
 FontPath "/usr/share/fonts/X11/cyrillic"
 FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
 FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
 FontPath "/usr/share/fonts/X11/Type1"
 FontPath "/usr/share/fonts/X11/100dpi"
 FontPath "/usr/share/fonts/X11/75dpi"
 # path to defoma fonts
 FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
 Load "bitmap"
 Load "ddc"
 Load "dri"
 Load "extmod"
 Load "freetype"
 Load "glx"
 Load "int10"
 Load "vbe"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "br"
 Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ImPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "stylus"
 Option "Device" "/dev/wacom" # Change to
       # /dev/input/event
       # for USB
 Option "Type" "stylus"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "eraser"
 Option "Device" "/dev/wacom" # Change to
       # /dev/input/event
       # for USB
 Option "Type" "eraser"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "cursor"
 Option "Device" "/dev/wacom" # Change to
       # /dev/input/event
       # for USB
 Option "Type" "cursor"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
 Identifier "ATI RADEON 9550"
 Driver "ati"
 BusID "PCI:1:0:0"
EndSection

Section "Monitor"
 Identifier "LG L1752S"
 Option "DPMS"
 HorizSync 31-80
 VertRefresh 70-75
EndSection

Section "Screen"
 Identifier "Default Screen"
 Device "ATI RADEON 9550"
 Monitor "LG L1752S"
 DefaultDepth 24
 SubSection "Display"
  Depth 1
  Modes "1280x1024" "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 4
  Modes "1280x1024" "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 8
  Modes "1280x1024" "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 15
  Modes "1280x1024" "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 16
  Modes "1280x1024" "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 24
  Modes "1280x1024" "1024x768" "800x600" "640x480"
 EndSubSection
EndSection

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Default Screen"
 InputDevice "Generic Keyboard"
 InputDevice "Configured Mouse"
 InputDevice "stylus" "SendCoreEvents"
 InputDevice "cursor" "SendCoreEvents"
 InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
 Mode 0666
EndSection

trylik (marek-nasionka) said : #3

first you need to install evdev driver

sudo apt-get install xserver-xorg-input-evdev
sudo apt-get install udev
sudo apt-get install logitech-applet

now type in konsole:
sudo logitech_applet --enable-cc

then type in konsole:
cat /proc/bus/input/devices

you should see something like this;
I: Bus=0003 Vendor=046d Product=c50e Version=2500
N: Name="Logitech USB Receiver"
P: Phys=usb-0000:00:10.1-1/input0
S: Sysfs=/class/input/input2
H: Handlers=mouse0 event1
B: EV=7
B: KEY=ffff0000 0 0 0 0 0 0 0 0
B: REL=143

remeber "event1" (in H line)

now in xorg.conf change this:
Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ImPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

into this:
Section "InputDevice"
    Identifier "MX1000"
    Driver "evdev"
    Option "CorePointer"
    Option "Device" "/dev/input/event1"
    Option "Buttons" "12"
    Option "ZAxisMapping" "4 5 7 6"
    Option "Resolution" "800"
EndSection

of course if you have other event number remember to change Device option here

now insert into:
 /etc/X11/XF86Config-4

this:
Section "InputDevice"
    Identifier "MX1000"
    Driver "mouse"
    Option "CorePointer"
    Option "Protocol" "evdev"
    Option "Dev Name" "Logitech USB Receiver"
    Option "Buttons" "12"
    Option "ZAxisMapping" "4 5 7 6"
    Option "Resolution" "800"
EndSection

Wladston Viana (wladston) said : #4

Done all that, restarted X - but the buttons aren't behaving as expected. Some of them act as a right click ...

Adam Smith (adamtropics) said : #5

The guide at https://help.ubuntu.com/community/MX1000Mouse works fine for me, take a look through it.

Wladston Viana (wladston) said : #6

Adam,

Just did the whole thing. The mouse works, but not the special buttons. :(

Wladston Viana (wladston) said : #7

ops, clicked the wrong button

Adam Smith (adamtropics) said : #8

Have you actually run 'xbindkeys' as well? (sorry, just had another look at the guide and noticed some of it is a bit 'small print' like)That should read the .xbindkeysrc file you created, and take care of 'special' keys, but not all in firefox. I have the thumb forward and back as firefox forward and back. The middle thumb as refresh, and the wheel left and right as left and right scroll. My .xbindkeysrc is...

"/usr/bin/xvkbd -xsendevent -text "\[Alt_L]\[Left]""
   b:8
"/usr/bin/xvkbd -xsendevent -text "\[Alt_L]\[Right]""
   b:9
"echo ButtonPress 4 ButtonRelease 4 | xmacroplay -d 0 :0.0"
   b:11
"echo ButtonPress 5 ButtonRelease 5 | xmacroplay -d 0 :0.0"
   b:12
"xvkbd -xsendevent -text "\[Control_L]\[r]""
  b:10

In my xorg mouse section...

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "evdev"
 Option "CorePointer"
 Option "Device" "/dev/input/event9"
 Option "ZAxisMapping" "4 5 6 7"
 Option "HWHEELRelativeAxisButtons" "7 6"
EndSection

Finally, in firefox about:config (<--enter that in address bar)

Change these settings for tilt wheel horizontal scroll

mousewheel.horizscroll.withnokey.action = 0
mousewheel.horizscroll.withnokey.sysnumlines = true

Don't just copy paste the xorg section, b ut just check the bits that are relevant against yours, since as I use it as corepointer, if it doesn't work, x doesn't start! Hope this info proves of some use.

Best Wladston Viana (wladston) said : #9

errmm ... that looks very complicated for a noob end user ... I think I'll go try to harass logitech for a linux driver instead ... :P

However, thanks for the reply!

AnRkey (anrkey) said : #10

Surely this warrants some attention from the dev team...

Users should not have to edit files and other gibble gobble to get a mouse working. It's easy enough to identify these mice, so whats the big problem with making them work "automagically" when they are plugged in???

That's my two bits worth, thanks for reading...

AnRkey :P

Wladston Viana (wladston) said : #11

Well, to update the issue :

I've talked to the logitech guys, or better, I fought on the logitech email tech support.

at the end, I got this reply :

"Wladston, I am unsure if there is any contact point for you to escalate the matter to the higher management."

and

"Wladston, I do believe that Logitech does want you as a valuable client. If not, I won't be here to give support to you for all this while. However, it is just that Logitech is unable to provide all solutions to all customers. "

Logitech declares she is "unable" to make the device it manufactures work on linux.

Reported a bug, let's hope some nice dev. fixes that ...