Add/Remove applications - cannot download

Asked by Asad Wali Khan on 2008-09-26

Hello to all,

I managed to install ubuntu on my laptop.
I have net access via my home windows pc LAN.
The add/remove applications does not load the list and it takes forever.
Stuck on file 11 and gives me an error.
The video player cannot play any of my files.mpg or .wmv
Modem was not detected.

Am I on the right track ?
Is it always so difficult ?

Thnx,

Asad Wali Khan.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2008-09-27
Last query:
2008-09-27
Last reply:
2008-09-27
Asad Wali Khan (hyamworks) said : #1

error is cannot download file in repositories

You are connected to Internet via a Windows PC? Or you are connected directly to a hub/switch/router???

Asad Wali Khan (hyamworks) said : #3

Jose,

Thnx for your response.
I am connected through my home network, a windows xp running a small proxy lets me connect.
I have a cross cable connecting the two network cards.
I can browse the net using firefox on ubuntu.

Best regards,

Asad Wali Khan.

Please create a proxy definition file under /etc/apt/apt.conf.d/proxy

Open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo gedit /etc/apt/apt.conf.d/proxy

give your user password when requested, you don't see nothing when you type it, then press enter.

Then write something like this:

Acquire::http::Proxy "http://192.168.1.40:3128/";

Or if you have set user and password to get proxy access:

Acquire::http::Proxy "http://your_proxy_user:your_proxy_user_password@your_proxy_ip:your_proxy_port/";

Thank you

Asad Wali Khan (hyamworks) said : #5

Jose and macrobra,

Thnx for your help.

It was a proxy problem with the Add/remove proxy.
I used Configuration Editor and set the proxy.
It is updating now.

Thnx for your help.

Best regards,

Asad

Asad Wali Khan (hyamworks) said : #6

Thanks marcobra, that solved my question.

Then some packages have to download some files using http or ftp connection so please sure you have set
your proxy under System->Preferences->Network Proxy

Or if you are using apt-get or aptitude via command line please also set the http_proxy and ftp_proxy exported variables
put them at the end of your $HOME/.bashrc file open a terminal and type:

gedit $HOME/.bashrc

add
export http_proxy=http://your_proxy_ip:your_proxy_port
export ftp_proxy=http://your_proxy_ip:your_proxy_port

or if your proxy need user and password

export http_proxy=http://your_proxy_user:your_proxy_user_password@your_proxy_ip:your_proxy_port
export ftp_proxy=http://your_proxy_user:your_proxy_user_password@your_proxy_ip:your_proxy_port

Save and exit, then type:

source $HOME/.bashrc

Hope this helps