intrepid update just killed my nvidia drivers...

Asked by Pablo Marchant

I just updated intrepid, and when restarting, X failed to initialize due to problems with the nvidia driver. I restarted on safe mode and issued the system to fix the x server, and now when X starts, I hear the startup sound, but I see nothing (my monitor says "out of range"). What happened?? I saw the update downloaded what it seemed to be version 177 of the nvidia drivers and build them, but I'm not sure.

I think i could make it start by using the vesa driver, but I've never been able to understand how to set this with the "new" xorg.conf. How do I setup vesa as the video driver??

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Bhavani Shankar (bhavi) said :


Intrepid is still in feature freeze and many packages are unstable.. as a result still testing is going on.. So please dont upgrade to intrepid as few packages have critical bugs and FTBFS and its buggy and uninstallable I suggest you to wait till the beta version is released if you are interested in trying out ubuntu which is due on oct 2nd..


Revision history for this message
Pablo Marchant (pamarca) said :

I know intrepid is still at alpha, but I've been using it for over a month with no problems until now...
The thing is, i'd like to repair the system so I can continue using and testing it (I have another partition with feisty that I can use meanwhile, but id really like to return to intrepid...).

The thing I need to find out to fix this is how to setup (via terminal) vesa as the video driver.

Revision history for this message
Bhavani Shankar (bhavi) said :
Revision history for this message
DanielB (danielhoney2-deactivatedaccount) said :

I had a problem with x and my nvidia Card (a 6600GT). It was similar i installed ubuntu studio and then it loaded ok until it booted the gnome display manager when it had funky colours and my monitor said it was an incorrect resolution.

When you hear the sound and but no pictures you can jump into a command prompt (?) screen by pressing Ctrl-Alt-F1.

then you can shut down x:
# sudo /etc/init.d/gdm stop

then grab the nvidia package:
# sudo apt-get install nvidia-glx-new

then configure x:
#sudo nvidia-xconfig

then you can start x again
#sudo /etc/init.d/gdm start

you can then jump back to x by pressing Ctrl-Alt-F7.

that worked for me, but im only using Hardy Heron, and you have the closed source drivers as well (and you get a massive nvidia splash screen when you start x).


Revision history for this message
unitybox (unitybox) said :

On a somewhat related note, I installed Intrepid and I was blown away with how well it ran especially the Internet stuff. It even supported my 5750 aircard right on the jump. I ABSOLUTELY LOVE where this is going. However upon the last update lastnight my audio died. I noticed it right away. I did another update about an hour ago and in the list of 60 things there was a update for pulse audio. When I rebooted I heard my startup sound but it was choppy. Is pulse a type of audio driver or a method of rendering audio so other programs can share. At any rate I would really like to revert to the old audio that worked fine and blacklist any future audio updates in the repo until that part is stable. Also on a strange note screen savers that worked flawlessly in Hardy now fail. Could be a link between open GL and audio since it's a unified chipset. ATI runs the video and audio. It's a Toshiba satellite a105 s101. Even without audio I find this a usable system I just think it worked better before the last update.

Revision history for this message
Endolith (endolith) said :

Just installed Intrepid release and had a similar problem. Can't start X.

Can you help with this problem?

Provide an answer of your own, or ask Pablo Marchant for more information if necessary.

To post a message you must log in.