Ubuntu 7.04 firefox connection problem

Asked by Zafster on 2007-03-29

I just updated my Ubuntu install from 6.10 to 7.04 at work where I am behind a firewall and proxy server. My system use to work perfectly. After I updated the Ubuntu 7.04 I can't get firefox to work properly. Each time I enter an adress I get:

Proxy Encountered Error
Error Receiving Data: Error receiving data from remote server. Possible causes include remote server error and transient network problems.

The weird thing is my Gmail notifier works and when I click on it I can access my gmail account but no other sites. Also I can access the internet using opera...

Please help.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-05-01
Last reply:
2007-06-19

This question was reopened

Can you check the proxy settings in Firefox are correct?

Edit --> preferences --> advanced --> network (tab) --> settings (button).

Are they the same as the settings in System --> preferences --> network proxy ?

I have not seen this error before, you could try reinstalling firefox. In a terminal (Applications --> Accessories --> Terminal)

sudo apt-get install mozilla-firefox --reinstall

Finally you could try moving the .mozilla directory to one side - in nautilus rename it to .mozilla-old or something. Then start firefox and set the proxy settings again and test it.

Zafster (z-leylek) said : #2

Ok, I tried all those and it did not work. I even uninstall the complete firefox package and its dependants and re-installed it again. I did however notice that firefox works for https. I am currently posting this message thru firefox as it is an https site. The problem then is with http & firefox.....

Any suggestions?

Ralph Janke (txwikinger) said : #3

Can you check if you have a different connection setting for the http protocol than the https protocol in Firefox.

The http settings are under HTTP Proxy, the https settings under SSL Proxy.

You need to check the host and the port.

I hope this helps

Zafster (z-leylek) said : #4

Yes, I have the same settings for all protocols. I entered the proxy server data into the http proxy and port boxes and checked "Use this proxy for all protocols".

Ralph Janke (txwikinger) said : #5

Hmmm. I am a little in a loss. In such a case, I usually use Ethereal and capture the packages that go in and out the network device in order to get some idea. Compare what packages are send/received for firefox http and https and as well for opera and look at the differences. Look for the source/destination addresses and ports in the packets on the ip level (network layer).

That could at least give a clue what to look for.

Could it be that the adminsitrators of your proxy have blocked access to users who are using Firefox? Yet they allow opera? It would be odd, but it is possible.

Can you change the user agent string in opera to make it pretend to be firefox, or in firefox to pretend to be opera to test this theory?

You can install the user agent switcher extension in Firefox to do this. I think this feature is included in Opera by default.

Zafster (z-leylek) said : #7

I install the user agent switcher extension and changed the user agent to Opera, Netscape and Internet explorer and in all cases Firefox worked.

My next question regarding this problem would be the cause of the problem and how to fix?

Thanks a lot for your help....

Does this happen for all sites you test with?

Can you test with the user agent set to firefox and visit some simple sites such as google.com?

If it still fails then contact the administrator who looks after your proxy server.

Zafster (z-leylek) said : #9

When I change it to "Default" which I assume is Firefox I get the proxy error message. When I change it to Netscape, Opera or Internet explorer Firefox works properly.

This problem started after I updated to Ubuntu 7.04. My machine is a dual boot system and I am able to use the Firefox version that runs in Windows 2000. Others at work are also using Firefox on Windows without any problems. I think the problem is with my Ubuntu installation (and maybe the update process).

To prove it then you could install the user agent switcher in your firefox under windows and get it to pretend to be Firefox under linux. See if the error occurs.

Zafster (z-leylek) said : #11

I also found this:

https://launchpad.net/bugs/95241

Sounds very similar to my problem.....

Worth noting that if you run Firefox on Windows and Firefox on Linux on the same machine the user agent WILL be different.

This is the user agent string for firefox under windows xp.
"Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3"

This is the user agent string for firefox under ubuntu feisty.
"Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)"

Same version of firefox, different OS.

Given your analysis on bug 95241, I would suggest you contact the administrator of the proxy server and attempt to identify why it acts the way it does.

HMX (matej-horvat) said : #14

It is enough to go to about:config and change

general.useragent.extra.firefoxComment to (Ubuntu 7.0.4) or something similar.

Avoid using the string "ist".

Solstace (chris-s-ferguson) said : #15

Any reason to avoid the string "ist"?

Zafster (z-leylek) said : #16

I have no idea. I would really love for someone to tell me why this problem is occuring as well!!!!

Ralph Janke (txwikinger) said : #17

Apparently there are commercial firewalls that have a bug (maybe it is an intended feature for something else?) that will drop connections from browsers sending this identification string. There are no problems using it with the squid web proxy.

esodan (esodan) said : #18

The change in about:config RESOLVES the problem:

Now I have working FireFox and Epiphany with the following change:

general.useragent.extra.firefoxComment

from

(ubuntu-feisty)

to

(ubuntu 7.04)

Marcel (mpgsmeets) said : #19

Hi,

Here a same sort of problem, maybe not the right forum, but the problem is very similar and maybe it will help the developers solve some bug.

Firefox 2.0.0.4 on windows XP SP2. Firefox is working for .com , .nl and other domains. But not for .net domains, like e-messenger.net or e-tones.net, server not found (which do work if using IE 6). Tried to change the useragent-String as stated above but nothing helped. Installed the User Agent switcher extension, but no solution there.

Here in the company they are using Checkpoint firewall, so something is going wrong with Firefox and Checkpoint firewall. Do not know what exactly....

Hope this will be solved between checkpoint and firefox

regards Marcel

Marcel (mpgsmeets) said : #20

Disregard the last post.

It looks like the problem was caused by a import error. The IE settings were imported in Firefox automatically. All proxy settings were imported correctly except one of the proxy exceptions:

......,localhost, .... was imported as ......,localho,t,.....

As a result of this all domains with a 't' weren't proxied, duhhhhh

Remains the question? Why was this rule imported like this, because IE 6 worked fine with the 't' domains

Marcel

Can you help with this problem?

Provide an answer of your own, or ask Zafster for more information if necessary.

To post a message you must log in.