ndiswrapper-1.35 cannot detect GCC in Dapper Ubuntu

Asked by Neal Gompa on 2007-03-29

I just installed Dapper Drake, and after much painstaking installing debian packages by hand because the ndiswrapper included in dapper is too old, I attempted to build ndiswrapper-1.35 from source. However, it was unable to detect gcc, and thus unable to build it. In case suggesting about the included ndiswrapper, the Netgear WG111T USB does not function on ndiswrapper-1.22 and below. Apparently there is a bug that was fixed in ndiswrapper-1.23, which is why I am asking about this gcc problem in Dapper Drake. Fresh installation, just the build-essential, gcc-3.4, linux-headers packages installed... Removed the original ndiswrapper modules...

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Ralph Janke
Solved:
2007-03-30
Last query:
2007-03-30
Last reply:
2007-03-30
Ralph Janke (txwikinger) said : #1

I guess you have a tar.gz file and try to compile the packet directly from the sources ?

The first thing you can check is what

gcc --version

displays on the commandline terminal.

If this gives you properly the version, gcc is properly accessible.

I also guess that you have the problem what you execute the configure script. please post the log file (configure.log or something similar) here (or the relevant lines from it) to give some more indication what the error messages are.

I hope this helps.

Neal Gompa (ngompa13) said : #2

Well, apparently, the gcc [meta?]package was not installed, so the variables
werent set for which gcc to use. So, I installed it and got the tarball to
work. Though I have to wonder why it had a version of ndiswrapper from 2005
in the first place..... in a version of Ubuntu from 2006....

On 3/29/07, txwikinger <email address hidden> wrote:
>
> Your support request #4470 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+ticket/4470
>
> Status: Open => Answered
>
> txwikinger proposed the following answer:
> I guess you have a tar.gz file and try to compile the packet directly
> from the sources ?
>
> The first thing you can check is what
>
> gcc --version
>
> displays on the commandline terminal.
>
> If this gives you properly the version, gcc is properly accessible.
>
> I also guess that you have the problem what you execute the configure
> script. please post the log file (configure.log or something similar)
> here (or the relevant lines from it) to give some more indication what
> the error messages are.
>
> I hope this helps.
>
> _______________________________________________________________________
> If this answers your request, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+ticket/4470/+confirm?answer_id=0
>
> If you still need support, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+ticket/4470
>

Best Ralph Janke (txwikinger) said : #3

Ubuntu puts emphesis on stable packages not necessarily the newest ones. If you want more bleeding edge, you probably should look at a distribution like gentoo or debian.

I hope this answers your question. Could you please set this question to resolved if it does.

Thanks

Neal Gompa (ngompa13) said : #4

User confirmed that the request is solved.