Ubuntu install fails at partitioning

Asked by Tolchok on 2008-08-29

I have played around a bit with the Ubuntu LiveCD and everything seems to work, except for the WLAN card which is an entirely different problem. I decided I liked it enough and went to install it. I went to Install, got through to where it wanted to make a new partition for Ubuntu. I told it to use something along the lines of 25 GB, leaving 80 GB for Windows XP. The partitioning window came up, and the disk spun for a while, but the bar never went past 0%. Eventually, it said it had failed to create the partition and dropped me into a manual setup. Not knowing how to manually adjust the partitions, I went back, to find that the option of resizing had disappeared. I gave up and switched back to Windows, to find that somehow my drive was "dirty" and DSKCHK had to verify things. Once DSKCHK did its thing, I could try the resize option on Ubuntu install again, but the same thing happened, and the drive was "dirty" again. I am concerned that this may end up causing some sort of irreversible harm to my hard drive if I just keep trying the install again.

Other info:
I am running a Dell Inspiron e1505. I have a dual core 1.66GHz Pentium Core2Duo Processor. I have a 16x(I think) CD/DVD drive. I have a 105GB hard drive, which is partitioned into sda1(FAT16), sda2(NTFS-here is windows), sda5, and sda4. I think that both of these last ones are FAT32, and one of them has MediaCenter something. There is also about 8megs free space

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Tolchok
Solved:
2008-08-30
Last query:
2008-08-30
Last reply:
2008-08-29
pankaj (pankaj-arora) said : #1

I have Ubuntu installed on my window vista premium edition HP laptop. my friend boot the CD and it ask ofr the partition itself e.g How much space u need for windows and how much for Ubuntu. u can actually resize that bar according to your need.

Tolchok (andywolfkid) said : #2

I am aware of that, I resized it to 25GB for Ubuntu, then when it goes to actually resize it, it says "An error occurred while writing the changes to the storage device. The resize operation has been aborted."

Hi, Tolchok.

gparted (the program used to make the partitions in graphical mode from the LiveCD, can't resize a FAT32 / NTFS partition unless it is marked as "clean / good" by windows.

Go into windows. Run Scandisk and reboot normally. Then, from the LiveCD, try using gparted again. It should work.

On the other hand: Did you check to see if your WLAN card is supported? I've had a few nightmares configurins laptops because of missing wireless drivers :(

Tolchok (andywolfkid) said : #4

Actually, I got it to work. I ran the install and manually resized the ntfs partition and created / and swap, and it installed fine.

I also got my WLAN card working. A little window in the corner told me there were firmware upgrades available. It turns out it just didn't have the drivers to the 4311 because they were proprietary, and downloaded them via ethernet cable fine.