How to choose OS when the arrow keys won't work in grub

Asked by lorenzino

I am trying to connect a keyboard called PC-Midi (by Creative) to be used in Windows 2000 OS. I have a dual boot MBR, which I believe is called Grub. So, when I see the screen to make the choice, the arrows will not work, so it times out and boots ubuntu. Then the keyboard works normally! How do I get into the Windows OS with this keyboard? I suppose the answer is to edit Grub, but how do you do that?

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Carlo Vanini (silhusk) said :

The configuration file of Grub is /boot/grub/menu.lst. You must edit it as root, e.g. with
gksudo gedit /boot/grub/menu.lst
you can change the default system by editing
default 0
This is NOT a Solution: arrows still do not work, but you changed default OS.

Revision history for this message
Simon Loggen (simonloggen) said :

I had a similar problem with my USB keyboard, I took a PS2 keyboard and it worked fine, this problem appeared on some older PC's I have so maybe it has something to do with USB keyboards not being recognised by the PC. I also had problems once with an 7 yr old machine that when I plugged in an USB mouse the PS2 keyboard didnt work anymore with GRUB.. anyway I hope you can find a solution with these things I ran into.

Revision history for this message
Matthew Lange (matthewlange) said :

I linked this ticket to bug 36342:

It seems to be the same problem you describe, but with another keyboard.

Revision history for this message
CYRUS (imtiaz-saeed) said :

Guys... guess wot im using a PS2 keyboard and it was working fine till yesterday but now the arrow keys are not working at OS selection menu. Furthermore, i cant get into my BIOS by hitting DEL key. The only thing i can do is ALT+CTRL+DEL to reboot. But when ubuntu starts it starts working fine. Pls help me in this regard!

Revision history for this message
CYRUS (imtiaz-saeed) said :

Thanks guys.. solved the problem by reseting the bios from mobo jumper.

Can you help with this problem?

Provide an answer of your own, or ask lorenzino for more information if necessary.

To post a message you must log in.