Can't connect to Internet - Ubuntu 8.04

Asked by Nick on 2008-08-27

Just yesterday I downloaded and installed Ubuntu 8.04. I must say I was very pleased with how easy the install went and look forward to using Ubuntu, however I am not able to access the Internet. I read several posts from people with similar problems, but haven't been able to figure out why I can't connect. To give a little background of my setup, I have a D-link WBR-1310 router (IP address = 192.168.0.1) which is connected to a 2Wire? DSL modem (I'll have to double-check the make and model); the computer is connected to the router via Ethernet cable. So, I ran the following commands I found in a similar post and posted the results below: lspci, lsusb, ifconfig & iwconfig. When I did this initially the computer didn't appear to be getting an IP address while set to use DHCP, so I set the IP address to a static address of 192.168.0.111, but still couldn't get online, nor could I ping the router's address successfully.

Any help with this problem would be greatly appreciated.

lspci
00:00.0 Host bridge: Intel Corporation 82810E DC-133 (GMCH) Graphics Memory Controller Hub (rev 03)
00:01.0 VGA compatible controller: Intel Corporation 82810E DC-133 (CGC) Chipset Graphics Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801AA PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corporation 82801AA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801AA IDE Controller (rev 02)
00:1f.2 USB Controller: Intel Corporation 82801AA USB Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801AA SMBus Controller (rev 02)
01:09.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 08)
01:0b.0 Ethernet controller: Lite-On Communications Inc LNE100TX [Linksys EtherFast 10/100] (rev 25)

lsusb
Bus 001 Device 002: ID 045e:0039 Microsoft Corp. IntelliMouse Optical
Bus 001 Device 001: ID 0000:0000

ifconfig
eth0 Link encap:Ethernet HWaddr 00:a0:cc:e1:51:c3
          inet addr:192.168.0.111 Bcast:192.168.0.255 Mask:255.255.255.0
          inet6 addr: fe80::2a0:ccff:fee1:51c3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:357 dropped:0 overruns:0 carrier:714
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          Interrupt:9 Base address:0xd800

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:2556 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2556 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:144120 (140.7 KB) TX bytes:144120 (140.7 KB)

iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Nick
Solved:
2008-08-29
Last query:
2008-08-29
Last reply:
2008-08-28
Brent Plummer (brentplummer) said : #1

Do you have the gateway 192.168.0.1 set in interfaces?

ethtool to check the speed/duplex/autoneg and set them accordingly?

ethtool -s eth0 speed 100 duplex full autoneg off ???? Just tossing out the basics!

Let me know if I can offer more options!

Bnix

Brent Plummer (brentplummer) said : #2

Did it help?

Nick (nvafakos) said : #3

thanks for the quick feedback; I'm not at home right now and will try your suggestions as soon as I can

Nick (nvafakos) said : #4

Tried your suggestions, but still couldn't establish an Internet connection; in fact there appears to be some kind of lock on the settings that you had me try to change (see below).

ethtool -s eth0 speed 100
Cannot get current device settings: Operation not permitted
     not setting speed

ethtool -s eth0 duplex full
Cannot get current device settings: Operation not permitted
     not setting duplex

ethtool -s eth0 autoneg off
Cannot get current device settings: Operation not permitted
     not setting autoneg

I wasn't quite sure where you meant for me set the gateway, but I had already set it in Network Settings, under Wired connection when I set the Static IP address. If there is somewhere else that it needs to be set, could you be more specific.

If you have any other suggestions I would appreciate it.

You probably need to set your DNS server to the same address as the gateway/router (192.168.0.1).

Brent Plummer (brentplummer) said : #6

You'll have to sudo those commands if you're not logged in as root.

copy and paste this command:

sudo ethtool -s eth0 speed 100 duplex full autoneg off

By setting the gateway, I meant setting it in the interfaces file.

copy and paste this command and let me know your output

sudo cat /etc/network/interfaces

Also your output for this

sudo ethtool eth0

Thanks
BNix

Nick (nvafakos) said : #7

Ok, I'll give that a try when I get home this evening and I'll post the results.

Thanks again for your continued help.

Nick (nvafakos) said : #8

ok, when i typed "sudo cat /etc/network/interfaces", i got the following:

auto lo
iface lo inet loopback

iface eth0 inet static
address 192.168.0.111
netmask 255.255.255.0
gateway 192.168.0.1

auto eth0

when i typed "sudo ethtool -s eth0 speed 100 duplex full autoneg off", i got the following:

Cannot get current device settings: Operation not supported
   not setting speed
   not setting duplex
   not setting autoneg

Nick (nvafakos) said : #9

Ok, this is strange . . . I set my network settings back to dhcp and when I run "sudo cat /etc/network/interfaces", i got the following:

auto lo
iface lo inet loopback

iface eth0 inet dhcp
address 192.168.0.111
netmask 255.255.255.0
gateway 192.168.0.1

auto eth0

So, I tried to ping the gateway, unsuccessfully, however it gives me the following:

PIN 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
From 169.254.9.239 icmp_seq=## Destination Host Unreachable

which makes sense, but doesn't make sense at the same time

so, i ran the ifconfig command again after having set DHCP and got the results below:

 ifconfig
eth0 Link encap:Ethernet HWaddr 00:a0:cc:e1:51:c3
          inet6 addr: fe80::2a0:ccff:fee1:51c3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:735 dropped:0 overruns:0 carrier:1470
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          Interrupt:9 Base address:0xd800

eth0:avahi Link encap:Ethernet HWaddr 00:a0:cc:e1:51:c3
          inet addr:169.254.9.239 Bcast:169.254.255.255 Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          Interrupt:9 Base address:0xd800

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:2961 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2961 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:192876 (188.3 KB) TX bytes:192876 (188.3 KB)

now i'm all confused . . . and starting to get frustrated

Nick (nvafakos) said : #10

well, after all that it appears to have been a bad NIC. I replaced it with a spare I had laying around at the suggestion of a friend and now I am able to get online no problem. Thanks for all the help.