Permissions problem, Ubuntu 8.04.1

Asked by Henry Peters on 2008-08-25

I recently unpacked a program (www.celtx.com-Celtx.tar.gz) I downloaded (right click, 'Extract here').

Previous to this, I tried using the extraction routine suggested by Celtx, using terminal, wouldn't work (I say this as possible prelude to problem).

In any case I dragged the program folder to my home folder, double clicked the program, it opens but will not function... (it functioned before I moved said folder to my home directory).

So today, I tried to trash it... it wouldn't do it (error: "Unable to trash file: Permission denied") then noticed that there was a lock on the file (& several other files in the home folder that I think were not locked before (?)) so naturally, I looked in the properties window & it said the 'owner' was "root."

I went into the terminal, in the root level, made the folder containing the program the cd, & did a "centx -R" This didn't work (i.e. trash said folder).

Question is: how do I get out of this conundrum... & also, importantly, how the heck do I not get into it in the first place?!

Hopefully, this is making some sense.

Thanks much,
Henry

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Andrew
Solved:
2008-08-27
Last query:
2008-08-27
Last reply:
2008-08-27
Andrew (and471) said : #1

Well, you can remove the files in the Trash by running in a terminal

sudo rm-rf ~/.Trash

I don't really know how the permissions thing happened, but at any rate, here is how to run it.

Put the archive where you want it to be installed (I recommend if only your account is using it [ if not post a reply saying so ], make a directory called 'Software' in your home directory and put a folder in there called centx), right click on it in the file manager and select 'Extract Here'. Then go into the newly created folder, and double click the 'centx' file.

If the running of that file doesn't work, please opena terminal, navigate to where the file 'centx' is, and run

./centx

Hope This Helps

Henry Peters (hwpeters) said : #2

Thanks for the considered reply!

I think I wasn't clear enough... the file would *not go to the trash,* in fact I could not move it out of its directory (home) any where. I do think you may be on the right (helpful) path, though... i.e., what I think I need to know further, is how (what) do I command for the actual path name of the file/s (i.e., folder/s locked to 'root') to be sent to trash & *then* 'emptied' from in the 'trash'? In other words; I believe if I could get the folder/s to the trash, from there on may not be a problem.

Also, I am anticipating the possibility there may be other users of this program (& even if not, would like to learn how to make a program accessible to more than one user (I did download 'Samba,' trying to activate that possibility within the 'properties' window, if that may (or may not) be relevant).

Thanks again Rugby, I do appreciate your thoughts.
Henry

Andrew (and471) said : #3

Right then, to remove these files, first what we need to do is (as root with sudo) use the rm command

sudo rm -rf <pathtoceltx>

Right, the 'rm' part is just the name of the remove program, the next bit '-rf' has two parts, the 'r' means search inside this directory, delete all files in there, and then delete this directory (r stabnding for recursively). The f standing for force, which tells rm not to keep asking me whether to delete the files ( a confirmation) as in this case, we *want* to get rid of them (you can take the f away if you really want to)

So now all we have left is the <pathtoceltx> part, you need to substitue this for the directory celtx has been extracted to, so if I had extracted it to my Desktop, i would run

sudo rm -rf /home/rugby471/Desktop/celtx/

Right so you now know how to delete this.

Now, what we want to do, is put the files for celtx in a location where all users will be able to access it. There exists a location just for packages like this that are standalone (ie. all files are together), we put them in /opt.

So if we downloaded the celtx package (called celtx.tar.gz) to my home directory, we would run these commands, to put it in the /opt directory

sudo mkdir /opt
(make the opt directory)

sudo tar xvpzf celtx.tar.gz -C /opt/

I hope this helps!

Andrew (and471) said : #4

Oh and to then run celtx, type in the terminal

/opt/celtx

Henry Peters (hwpeters) said : #5

Hi Rugby,

Thanks! I'm almost there... :)

The locked version is now history, as the saying goes.

The program (now in /opt) opens, but still is not functional... I'll probably have to get back to Celtx with this though.

The 'sudo mkdir /opt' was not really necessary, as there already existed such a directory... but it was good practice for other directory making.

The only thing you may be able to help me with now, is how do can I get the run icon in my applications menu (or is this even possible with such an install?)?

Thanks again.

Henry

Andrew (and471) said : #6

Yep sure, right click on the menu and select 'Edit Menus...'

Then the menu editor should pop up, in the left sidebar, click in the audio & video category and then once you have done that, click on the 'New Item' button on the right hand side.

A dialog should pop up, enter the following details

Type: Application
Name: celtx
Command: /opt/celtx/celtx
Comment: All-in-one media pre-production software

(Set the icon to anything you want)

Click okay and then in the editor, click close

You will now find the menu item in Applications > Sound & Video > centx

I may also be able to help you with the centx problem, did you get any output (errors, messages etc.) when you ran

/opt/celtx/celtx

In the terminal

Henry Peters (hwpeters) said : #7

Thanks again Rugby,

I got celtx on my application menu, one problem there was when I was installing said, & went to look for an icon to install... there were no icons available in the window... I tried browsing but knew not where to look (or even if I needed to custom make myself), so I have some kind of generic icon now, no big issue, but if you have some knowledge of this area, I'm interested to know how to do this (in early mac OS, which I used for a some years, there was a cut & paste method) if you are willing to share.

There was no error info when I ran the program from the terminal... infact, no message at all, except the normal next ':~$' line, however, when I tried to close the window, & therefore the program by the x box on the upper right, I get an error box with the 'details' being:

Celtx version: 1.0
Locale: en-US
OS: Linux x86-gcc3
Exception: TypeError: gProjMgr has no properties

Stack:
JS frame :: chrome://celtx/content/celtx.js :: tryToCloseProject :: line 2423
JS frame :: chrome://celtx/content/celtx.js :: closeWrapper :: line 2355
JS frame :: chrome://celtx/content/celtx.xul :: onclose :: line 1
native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

I do not know if this will help, but the 'gProjMgr has no properties' looks kinda suspicious... )(?)(

Henry

Best Andrew (and471) said : #8

Hmm, i searched the error message you got, and found this page

http://forums.celtx.com/viewtopic.php?t=7625&postdays=0&postorder=asc&start=15&sid=6a5857c07a9b005c98e7fac32c668374

It seems you need to delete your

.greyfirst
&
.celtx

directories, and then it should work (they are in your home directory, but are hidden, in the file manager, press Ctrl+H and you should then be able to see them)

About the menu item, when you browse for it, you need to put in the folder where the iucon you want is, so for example, I shall download a celtx icon from

http://macapper.com/wp-content/uploads/2007/11/celtx-icon.png

I save it to my Home Directory, so when I browse for an icon, I put in the top

/home/rugby471/

and then it shows me all images in there, i se;ect my celtx icon and there you have it!

Henry Peters (hwpeters) said : #9

Thank you, thank you!

Rugby, you are a very good problem solver here. Much appreciation for your help!

Best regards,

Henry

Henry Peters (hwpeters) said : #10

Thanks rugby471, that solved my question.