Unable to delete menu.lst copy

Asked by Dinesh

I modified the Grub Menu (menu.lst) file. And I made a backup of this file (menu.lst) using 'Save as' option..

I more this that backup file.. Now I am getting error when i attempt to delete this file which shows "Permission denied"..

The file location is /home/dinesh/Documents/Back Up/menu.lst

Please this me to fix this...

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Benjamin Drung
Last query:
Last reply:

This question was originally filed as bug #260493.

Revision history for this message
Benjamin Drung (bdrung) said :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs .

Revision history for this message
Best Benjamin Drung (bdrung) said :

The backup file is owned by root. There are various methods to solve this problem:

1) run following command in a terminal:
sudo rm "/home/dinesh/Documents/Back Up/menu.lst"

2) run "sudo nautilus" in a command and delete the file there.

Revision history for this message
Alex Ruddick (alexrudd0) said :

Your problem is that menu.lst is an important system file (if it is deleted, you cannot boot your system). This means the owner is "root", or the superuser. You will have to use "sudo" to give yourself permission to delete it. (Think of sudo as "Superuser do").

The easiest way is to type this in a terminal
"sudo rm /home/dinesh/Documents/Back Up/menu.lst"
(rm = ReMove, or delete, and putting sudo before it gives you the permission)

You can also use the file manager, "nautilus" as a superuser. (I recommend using the terminal instead since you can accidentally delete stuff very easily like this)

Press Alt-F2 and type
"gksudo nautilus"
(gksudo is the same as sudo, but for graphical ("gk") applications.)
Then navigate to /home/dinesh/Documents/Back Up and delete the file.

Revision history for this message
Dinesh (dineshaero) said :

Thanks Benjamin Drung, that solved my question.