Installed Ubuntu 8.04 server, only goes to command line?

Asked by prodigy200424 on 2008-08-22

Installed Ubuntu 8.04 Server, it only goes to the "command line" as with, can I say it here, DOS. I've read it could be the GUI with the server edition???Not sure on this, but there again, first time I even missed with this was last night and figured it's time to learn.

I'm new to this operating system and not only want to learn all about this, I am going to use this old system of mine to run a fantasy football website for the stat tracker updates instantly. Statfink.

Operating system is a P4 1.3, 256 ram, 400fsb, 40g hd, which should more than enough to handle what I want to do. Should I have only installed the 8.04 and not the server?

Just a guide in the right direction and I'll figure it out. Also what other goodies should I get for this?

Thanks for your time.
Dan

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Andrew
Solved:
2008-08-25
Last query:
2008-08-25
Last reply:
2008-08-22
Best Andrew (and471) said : #1

Don't Worry, you were correct in installing the server edition.

However since the server edition is normally used by command-line gurus :-), the server edition comes default without a gui, however you can easily install one.

Once you have loaded the server, and logged in, run the command

sudo apt-get install *****-desktop

You will need to replace ***** with the version of the ubuntu gui you wish. Below is a list of different options

kubuntu-desktop - For KDE
ubuntu-desktop - For GNOME (default with Ubuntu desktop)
xubuntu-desktop - For XFCE

If you have no clue about which one to choose, use ubuntu-desktop

Right after you have entered that command, enter your password, and answer yes (y) to all of the questions. Then it should install the GUI, this will take a long time, so get a book at the ready!

Once it has finished, enter the command

sudo shutdown -r now

To reboot the PC and next time it loads, you should boot into a GUI!

Hope this helps

prodigy200424 (dan-jerby) said : #2

Thanks rugby471, that solved my question.

Andrew you're a genius. Had the same problem and your fix worked.

Andrew (and471) said : #4

Hehe don't know about the genius part but thanks and I am glad it worked for you :)