Live session user does not detect hard drives

Asked by Laforja

My computer is intel based, running Vista, 2 internal hard drives. Vista does not launch. I am using Ubuntu as Live session user from CD to use the computer. Ubuntu does not detect the two internal hard drives so I cannot access the data files.
Internet access via ethernet OK, printer detected, USB external hard drive detected and Ubunto applications all load.
I have tried to follow instructions to solutions to similar problems, to no avail - maybe I have not understood them, I expected to load Ubunto like Windows and see the whole computer.
I would appreciate advise on how to make the two hard drives visible under Ubunto live session user. If this involves using the terminal, please give simple/precise step by step instructions to a novice user.
Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Laforja
Solved:
Last query:
Last reply:
Revision history for this message
Trygve Vea (trygve-vea-gmail) said :
#1

Hello

You say that Vista does not launch. Have you excluded the possibility that this is caused by that the harddrives are unavailable? Can you see them in the BIOS? Are they properly connected?

Those things would of course affect Ubuntu as well :)

Regards, Trygve

Revision history for this message
Laforja (paul-smith-bcn) said :
#2

Hello Trygve
Yes, BIOS recognises sata4 (ch4 M) and sata5 (ch5 M). So I understand that the two drives, which are internal, are connected and recognisable.
Any help is appreciated.
Regards, Laforja

Revision history for this message
Laforja (paul-smith-bcn) said :
#3

More information. I clicked in top line menu of the desktop, on System: Administration of Partitions Editor and saw the following:
/dev/sda - GiB, file system not assigned
/dev/sdb - GiB: information on this drive:
  /dev/sdb GiB extended
        /dev/sdb5 ntfs GiB
        /dev/sdb6 fat 32 GiB
        Not mounted.
Does any of this information help?
Best regards, Paul

Revision history for this message
Trygve Vea (trygve-vea-gmail) said :
#4

Hello

First I want to explain to you what the output means:

/dev/sda and /dev/sdb are the physical hard-drives. /dev/sdb5 and /dev/sdb6 are partitions on /dev/sdb.

About sda ... Since the partition editor is unable to enumerate any partitions on this drive - this most likely tells us that something really bad has happened to the partition table, and possible the entire drive. Since this is the first drive, I assume that your Vista-installation resides on that drive.

You should be able to access sdb5 / sdb6 fairly easy ... You may need to mount them though. This can be done by running the following commands in a terminal:

sudo su
mkdir /mnt/sdb5
mkdir /mnt/sdb6
mount -t ntfs /dev/sdb5 /mnt/sdb5
mount -t vfat /dev/sdb6 /mnt/sdb6

If you now browse to /mnt/sdb5 and /mnt/sdb6 using nautilus or simular, you should be able to access any files located on those two partitions.

I hope this helps :)

Regards, Trygve

Revision history for this message
Laforja (paul-smith-bcn) said :
#5

Thanks again. I followed your instructions with the following result:
root@ubuntu:/home/ubuntu# mkdir /mnt/sdb5
root@ubuntu:/home/ubuntu# mkdir /mnt/sdb6
root@ubuntu:/home/ubuntu# mount -t ntfs /dev/sdb5 /mnt/sdb5
$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sdb5': OperaciĆ³n no soportada
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
          clicking on the 'Safely Remove Hardware' icon in the Windows
          taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
          your own responsibility. For example type on the command line:

            mount -t ntfs-3g /dev/sdb5 /mnt/sdb5 -o force

    Or add the option to the relevant row in the /etc/fstab file:

            /dev/sdb5 /mnt/sdb5 ntfs-3g force 0 0
root@ubuntu:/home/ubuntu# mount -t vfat /dev/sdb6 /mnt/sdb6
root@ubuntu:/home/ubuntu#

Before proceeding with choice 2, can you advise what is implied by "you can use the 'force' option for your own responsibility"? Does this imply that I can endanger the contents of that disk for example?
Regards, Laforja

Revision history for this message
Trygve Vea (trygve-vea-gmail) said :
#6

That is exactly what it means. However, that risk SHOULD be reduced if you mount it as read-only. This can be done like this:

mount -t ntfs -o force,ro /dev/sdb5 /mnt/sdb5

I hope this helps :)

Regards, Trygve

Revision history for this message
Laforja (paul-smith-bcn) said :
#7

OK I will now think through my options. Many thanks for your help.
Best regards Laforja

Revision history for this message
Erics (stockman-eric) said :
#8

A reply a 'bit' overdue ?

An easy way to check whether Ubuntu has 'seen' your drives is with the terminal-window command ->
    ls -al /dev/disk/by-label

I label all my partitions on my disks and memory-sticks , makes live easier for me and for Ubuntu ,
  using label-names such as VISTA_C ... XP_D for my Windoze-partitions
     BOOT HOME JAUNTY904 etc ... for my Ubuntu partitions .
Makes it easy for mounting them or adapting the /etc/fstab file using LABEL=VISTA_C instead of the UUID= ...crap.....

another possible command = sudo sfdisk -l

Hopes this helps.
E.S