DVD playing on my HP AMD64 laptop

Asked by Sean

having just downloaded and installed Hardy heron I tried to watch a DVD but what I get is a box stating ""could not read from resource" Would appreciate some direction to get it right
thanks in advance

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Jim Hutchinson (jphutch) said :

If you are trying to watch a commercial dvd, chances are you need to add a package so that ubuntu can decrypt the dvds. Because of licensing issues it can't be included by default. See https://help.ubuntu.com/community/Medibuntu for the info you need. Pay attention to https://help.ubuntu.com/community/Medibuntu#Playing%20Encrypted%20DVDs for the how to on installing libdvdcss2 which is what you need for encrypted dvds.

Revision history for this message
Sean (mareshah) said :

Hello Jim this as far as I got
abraham@abraham -laptop:~$ wget -c http://packages.medibuntu.org/pool/free/libd/libdvdcss/libdvdcss2/_1.2.9-2medibuntu4_amd64.deb
--17:18:15-- http://packages.medibuntu.org/pool/free/libd/libdvdcss/libdvdcss2/_1.2.9-2medibuntu4_amd64.deb
           => `_1.2.9-2medibuntu4_amd64.deb'
Resolving packages.medibuntu.org...,
Connecting to packages.medibuntu.org||:80... connected.
HTTP request sent, awaiting response... 404 Not Found
17:18:15 ERROR 404: Not Found.

abraham@abraham -laptop:~$ sudo dpkg -i libdvdcss2_1.2.9-2medibuntu4_amd64.deb
sudo: unable to resolve host abraham -laptop
abraham@abraham -laptop:~$

Revision history for this message
Trygve Vea (trygve-vea-gmail) said :

If you're using Ubuntu 8.04 (Hardy):

Your problem is most likely solved by using the Add/Remove Programs, and installing the: "Ubuntu Restricted Extras" package.

I hope this helps :)

Regards, Trygve

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
Revision history for this message
Sean (mareshah) said :

firstly I found restricted extras and selected and apllied changes it was downloading for a very long time and it didnt end downloading so I aborted it.

I visited the above http>//packages etc and didnt quite know what to do..

Revision history for this message
Deepak Mishra (dpux) said :
Revision history for this message
Sean (mareshah) said :

I was finally able to access add/remove and install restricted extras.Hope it does what you suggest
thank you