Is It Possible to Play KUSC or XLNC1?

Asked by Lawrence H. Bulk

I have installed every audio codec I can find and I have even installed the RealPlayer for Linux. I can play most ShoutCast radio stations and quite a few other station but I cannot play KUSC (Home page: < > mp3 URL: < >) nor can I play XLNC1 (Home page < > "Listen Now" URL < >).

I can hear the introductions but after that is finished, the music does not play. In the case of XLNC1, the RealPlayer attempts to connect but a message pops up telling me that I am missing "mms." I do have as many of the xmms files installed as can be (with some I get a message stating that they cannot be installed) - if I enter "xmms2" in the Synaptics Package Manager search box, all the programs which appear are checked as installed.

Has anyone else tried to listen to these stations? Is it possible for me to do so? Any help will be much appreciated.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Trygve Vea (trygve-vea-gmail) said :

KUSC seems to work fine in Rhythmbox (just add the URL as a internet radio station from the menu), Totem and mplayer.
XLNC1 seems to work fine in Totem and mplayer.

You should not need to install any third party software as far as I can tell.

About XLNC1: If clicking "Listen Now" does not open the stream in Totem, you could do the following:

1) Right Click "Listen Now" and choose "Copy Link Location"
2) Start Totem manually
3) Browse the menu: Movie -> Open Location
4) Paste the link, and click "Open"

Totem should now play the music as intended.

I hope this helps :)

Regards, Trygve

Revision history for this message
Lawrence H. Bulk (lhbcomm) said :

No luck. I had tried both of your suggestions on my own previously. I have subsequently added some more mp3 programs and I tried them both again just now but I still cannot hear either of these stations.

It's not as though I don't have plenty of other stations to which I can listen. I'll just have to do without these two.

I wrote to XLNC1 about this problem and asked them if they would consider supporting Ubuntu/Linux. They never replied to me. My local classical music station WRTI has a "generic mp3 stream" which works perfectly (although they transmit only in mono). I do not know why KUSC and XLNC1 don't use such a stream too. (It is administered by a company called StreamGuys.)

Thanks for trying to help me, though.

My favorite station is on ShoutCast; it is "Play Classical UK."

Revision history for this message
Trygve Vea (trygve-vea-gmail) said :

But what happens if you try to play the streams in Totem and Rhythmbox?

(XLNC1 in Totem, KUSC in Rhythmbox)

Do you recieve any error messages or so, or does the music simply not play?

Revision history for this message
Lawrence H. Bulk (lhbcomm) said :

Hi Trygve,

When I try KUSC in Rhythmbox, nothing at all happens. When I try it with the Linux RealPlayer, I hear the introduction but nothing else. (The download shows only that a small file - presumably that introduction - was downloaded.) It does not pick up the streaming media.

Ditto for XLNC1. But there, if I just click on the Listen Now box, the Linux RealPlayer comes up, I hear the introduction, then nothing and then i do get an error message that I'm missing the plugin mms. This also happens with the Helix player.

I've got every mms plugin that I can find downloaded and installed. So I can't figure this out.

But, as I said to you previously, as far as I am concerned, it's THEIR problem. They will have lost a listener. There are certainly plenty of other internet radio stations to which I can listen (especially "Play Classical UK" which I like very much).

Thanks for trying to help me. I really appreciate it.

Revision history for this message
Trygve Vea (trygve-vea-gmail) said :


In Rhythmbox - does nothing happen even though the play-button is pushed down? You don't even see the "Buffering"-progress bar in the lower right corner of the window?

When it comes to XLNC1 --- I'm repeating this question because I'm unsure of your answer: Have you attempted to play the stream in Totem? What happens in Totem?

Glad to help :)

Regards, Trygve

Revision history for this message
Lawrence H. Bulk (lhbcomm) said :

When I try to play KUSC in Rhythmbox, I enter the URL for its streaming media into the New Internet Radio Station

< >.

When I try to play it, NOTHING happens - no "buffering," "connecting" - absolutely nothing. It just sits there.

If I click on the RealPlayer, in the Listen Live section, I will hear the introduction (I see a small download) but then the RealPlayer does not play the live stream.

When I try XLNC1 in Totem (Movie Player, Movie Player (GStreamer) and Movie Player (xine), absolutely nothing happens (except sometimes the program freezes and I have to "Force Quit").

If, in Firefox, I click on the Listen Now button in XLNC1, I will hear the introduction but then nothing and a message pops up saying I am missing a component. The following URL is displayed within the message that states I am missing "mms:"

< mms://xlnc1.wmlivesvc.vitalstreamcdn.comlive_xlnc1_vitalstream_com_X >

Even if I enter that or try to enter that in the address bar, absolutely nothing happens.

Have you actually tried playing either of these two stations yourself? Have you been able to hear the stream?

Thanks for trying.

Revision history for this message
Trygve Vea (trygve-vea-gmail) said :

Yes I have --- and they both work fine for me.

I'm sorry that this doesn't work for you. But I want to confirm this for you: The streams deliver the content they promise, and they are playable from Ubuntu.

Revision history for this message
Trygve Vea (trygve-vea-gmail) said :

Want to add that I've tested this on Ubuntu Hardy (8.04)

Regards, Trygve

Can you help with this problem?

Provide an answer of your own, or ask Lawrence H. Bulk for more information if necessary.

To post a message you must log in.