installing build-essential

Asked by john bridgen on 2007-03-08

 iam trying to install build-essential, checkinstall and libgtk1.2-dev and when found it in synaptic i got as follows
build-essential:
 Depends: libc6-dev but it is not going to be installed or
 libc-dev
 Depends: gcc but it is not going to be installed
 Depends: g++ but it is not going to be installed
the following pagages have unresolved dependensies and to make sure that the reposetries are loaded
what does that meen and how do i go about it
 thanks for any help

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Leandro Gómez
Solved:
2007-03-08
Last query:
2007-03-08
Last reply:
2007-03-08
Best Leandro Gómez (leogg) said : #1

Hi John!

In the console, type:

sudo aptitude update
sudo aptitude install build-essential

Good luck!

thanks leo problem solved
all the best john

User confirmed that the request is solved.

Hello John;

here im my ubuntu dapper drake, this steps doesen't work. I used:

$ sudo aptitude update
$ sudo aptitude install gcc build-essential

Works fine!

tks Leo

thanks jose i have now a mac and on ubuntu on a ppc it is synaptic
all the best john

Lealcy B. Junior (lealcy) said : #6

The Leo's solution solved my problem too. Thank you

denlip (denlip) said : #7

The Leo's solution solved my problem in vm.

Hello friends
I am using ubuntu 6.06 and using the ubuntu since 2000 but today facing this problem for the first time and unfortunately i m not able to fix this issue , details are

When i try to install package build-essential , it gives me errors ,

 root@linux-pk:/etc/apt# apt-get install build-essential
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  build-essential: Depends: libc6-dev but it is not going to be installed or
                            libc-dev
                   Depends: g++ (>= 4:4.0) but it is not going to be installed
E: Broken packages

-------------------------------------------

I have tried out every possible way , but i m getting same error every time i try to install the build-essential package

I have search the google and forum , but this problem is still there with no solution , i have update and re copy my sources.list , and tried out most common ways to fix the problem , example apt-get install -f and dpkg --configure -a , but nothing works for me , please kindly help me in fixing this package ,

Salman Awan (salmanawan87) said : #9

@ Leandro Gomez,

I have tried

           sudo aptitude update

but it gives error

E: could not get lock /var/lib/apt/lists/lock - open (11 resource temporarily unavailable)
E: Couldn't lock list directory..are you root?

whatis this eeror and what should i do now ?

@Salman

Be sure only one package manager is running... (please close synaptic and other...)

Sometimes if you have the System→Administration→Software sources [updates] Automatic updates active, the system usually after startup try to download and install the incoming security updates. To make this check it use a package manager.

So to be sure you have no any, automatic or opened by you, active package manager i suggest you to reboot your pc and try to repeat command or wait some time and repeat the command.

In Ubuntu 8.10 if a package manager is active you see a top right (near date) grey icon... (like a little sun)

Hope this helps

gareth (garethbaxter) said : #11

Hi All,

I am having a similar problem with dependencies in c compilers.
At first I had the same problem as John, header files not found. Now build-essential won't install because of 'unmet dependencies':

//=============================
sudo aptitude install build-essential
Reading package lists... Done
Building dependency tree
Reading state information... Done
Initializing package states... Done
Writing extended state information... Done
Building tag database... Done
The following packages are BROKEN:
  g++ g++-4.3 libstdc++6-4.3-dev
The following packages are unused and will be REMOVED:
  fgfs-base libcal3d12 libode0debian1 linux-headers-2.6.24-23
  linux-headers-2.6.24-23-generic plib1.8.4c2 python-cerealizer
  python-editobj python-pyogg python-pyvorbis python-soya python-tofu
  simgear0
The following NEW packages will be automatically installed:
  dpkg-dev libc6-dev libgmp3c2 libmpfr1ldbl libtimedate-perl linux-libc-dev
  patch
The following NEW packages will be installed:
  build-essential dpkg-dev libc6-dev libgmp3c2 libmpfr1ldbl
  libtimedate-perl linux-libc-dev patch
0 packages upgraded, 11 newly installed, 13 to remove and 0 not upgraded.
Need to get 1479kB/11.1MB of archives. After unpacking 436MB will be freed.
The following packages have unmet dependencies:
  libstdc++6-4.3-dev: Depends: gcc-4.3-base (= 4.3.2-1ubuntu11) which is a virtual package.
                      Depends: libstdc++6 (>= 4.3.2-1ubuntu11) but 4.2.4-1ubuntu3 is installed.
  g++-4.3: Depends: gcc-4.3-base (= 4.3.2-1ubuntu11) which is a virtual package.
           Depends: gcc-4.3 (= 4.3.2-1ubuntu11) which is a virtual package.
           Depends: libc6 (>= 2.8~20080505) but 2.7-10ubuntu4 is installed.
  g++: Depends: cpp (>= 4:4.3.1-1ubuntu2) but 4:4.2.3-1ubuntu6 is installed.
       Depends: gcc (>= 4:4.3.1-1ubuntu2) but 4:4.2.3-1ubuntu6 is installed.
       Depends: gcc-4.3 (>= 4.3.1-1) which is a virtual package.
Resolving dependencies...
open: 5882; closed: 4782; defer: 0; conflict: 107 o
No solution found within the allotted time. Try harder? [Y/n]

//==================================

Can somebody help me with this? seems to be wanting gcc-4.3 but it can't be found.

thanks
Gareth