Nautilus problem screen offset

Asked by Luis M.Jacinto on 2016-10-28

Don't know if I should reopen the question.
This to refer question 403401.
The Manfred suggestion it works very well but problem not fixed.
After rebooting Nautilus and others are back to upper left corner, notice that Firefox does the same with
the mouse you drag from its position.
Changed the URL on the end from 0 to 1 and if copied and insert in Firefox it opens.
https://www.dropbox.com/s/dg6j140oo82kefg/Screenshot%20from%202016-10-25%2006-13-13.png?dl=1
Please help to fix this
Thank you

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Luis M.Jacinto
Solved:
2017-03-02
Last query:
2017-03-02
Last reply:
2016-11-06

If you double click the bar with "Home" in it does it maximised OK?

Luis M.Jacinto (ljacinto) said : #2

No it does nothing only if press Alt F7

Manfred Hampl (m-hampl) said : #3

What happens if you open Nautilus (I understand that it will be positioned partly hidden), then move it towards the center of the screen, close nautilus and start it again. Where is the window positioned now?

Some programs store the last window position and size in their config file. It may be possible, that you have wrong access rights settings on some of these files, such that you can read the file (causing positioning the window at the wrong address stored in the file), but cannot write the new correct window position back into the file.

What output to you get for the command

sudo find ~ ! -user `logname` -ls

Luis M.Jacinto (ljacinto) said : #4

ried your suggestion two times but always gos back to the same position, its not only Nautilus Terminal,
Ubuntu Software, Firefox but Firefox you can move to the center screen others dont.

luis@luis-Ubuntu-16:~$ sudo find ~ ! -user `logname` -ls
logname: no login name
[sudo] password for luis:
find: ‘-ls’ is not the name of a known user
luis@luis-Ubuntu-16:~$

Manfred Hampl (m-hampl) said : #5

Sorry, the command did not work the way I suggested, try a modified one:

sudo find ~ ! -user luis -ls

Luis M.Jacinto (ljacinto) said : #6

luis@luis-Ubuntu-16:~$ sudo find ~ ! -user luis -ls
[sudo] password for luis:
 25828595 4 drwx------ 3 root root 4096 Jun 7 09:11 /home/luis/.dbus
 25828633 4 drwx------ 2 root root 4096 Jun 7 09:11 /home/luis/.dbus/session-bus
 25828635 4 -rw-r--r-- 1 root root 464 Jun 7 09:11 /home/luis/.dbus/session-bus/1e16218585094a3ca9d33eecb51464ac-0
 25953696 4 drwx------ 2 root root 4096 Jun 7 09:12 /home/luis/.cache/dconf
luis@luis-Ubuntu-16:~$

Manfred Hampl (m-hampl) said : #7

ok, there are some file/directories with wrong ownership settings.
Even if I doubt that this is the cause for your problem, you should correct that.

Try

sudo chown -R luis:luis /home/luis/.dbus
sudo chown -R luis:luis /home/luis/.cache/dconf

Then logoff and logon again.

Finally re-try
sudo find ~ ! -user luis -ls
to check whether there are still some files listed.

Luis M.Jacinto (ljacinto) said : #8

Following your request
luis@luis-Ubuntu-16:~$ sudo chown -R luis:luis /home/luis/.dbus
[sudo] password for luis:
luis@luis-Ubuntu-16:~$ sudo chown -R luis:luis /home/luis/
luis@luis-Ubuntu-16:~$
Then logoff and logon again.
luis@luis-Ubuntu-16:~$ sudo find ~ ! -user luis -ls
[sudo] password for luis:
luis@luis-Ubuntu-16:~$
Open Nautilus, unfortunately still the same
Thank you for all your effort to fix this.

Manfred Hampl (m-hampl) said : #9

ok.
If you now open nautilus, move it to the center of the screen (and resize the window that it fits on the screen), then close nautilus and finally open it again, where is the window located?

Luis M.Jacinto (ljacinto) said : #10

It worked only if Click on Maximize then did the same to Ubuntu Software again it worked I Restart Ubuntu and check Nautilus and it was correct with full page on the screen.
Then resize screen smaller and close Nautilus and open again and was back to the previous top left corner position.

Luis M.Jacinto (ljacinto) said : #11

I hope I didn't offend Manfred or anyone.
I did an Ubuntu update but it didn't fix.
I am stuck with this and Ubuntu 16.04 is not working properly at all can anyone help before this
question gets Expired

Please help
Thank you

Manfred Hampl (m-hampl) said : #12

Maybe you should consider a clean new installation.

Luis M.Jacinto (ljacinto) said : #13

This fixed my problem
Open Unity Tweak Tool
Window Manager > General
Click "Restore Defaults"