Unable to update from dapper to edgy

Asked by moose on 2007-03-05

I am unable to upgrade from dapper (6.06 LTS) to edgy (6.10). Whenever I run the package manager app or apt-get, it tells me that there are no updates available. However, when I run lsb_release -a, it tells me that the version is still 6.06. I've tries changing /etc/apt/sources from dapper to edgy with no effect. Thanks for any help on this.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
moose
Solved:
2007-03-09
Last query:
2007-03-09
Last reply:
2007-03-08
williamts99 (williamts99) said : #1

I have time to answer one question today, and yours is it. :-)

To upgrade from Dapper to Edgy, please follow the guide on:
https://help.ubuntu.com/community/EdgyUpgrades

Please though, make sure to follow the recommended method, and avoid the 'not recommended' method.

Best Regards,
Williamts99

williamts99 (williamts99) said : #2

Oh, yea, the recommended way, just to clarify is by using the Update Manager, not apt-get.

moose (moose-quadruped) said : #3

Thanks. Unfortunately, I tried this before I submitted the help request. This technique only opens the package manager - and that determines that no updates are available.

Kees Cook (kees) said : #4

From the command line, when you run the command:

  gksu "update-manager -c"

What options are you shown? This should work to allow a Dapper -> Edgy upgrade.

moose (moose-quadruped) said : #5

When I run gksu "update-manager -c, the update manage runs automatically, checking for updates. It reports that my system is up to date. I can rerun the check request and get the same result as many times as I like.

williamts99 (williamts99) said : #6

Ok, please go back into your sources.list file and edit it back to edgy, then try again.

Best Regards,
Williamts99

williamts99 (williamts99) said : #7

Sorry about that, I meant to say Dapper

moose (moose-quadruped) said : #8

This largely worked. The update complained that it could not update firestarter. A manual update afterwards also failed. Do you know if this is supposed to work with edgy? If so, what should I do to get it upgraded?

williamts99 (williamts99) said : #9

How did you install firestarter?

Best moose (moose-quadruped) said : #10

I used the synaptic installer. I've found now that if I remove the package completely then reinstall, it installs correctly. Thanks for your help.