When I tryed enstalling ubuntu 8.04 the disterbution upgrade window stalled and now is non fuctional at towards the end of the insillation part of the install

Asked by Homer on 2008-07-21

not sure what other info I can prode to you other than my system and that is Biostar/ floppydrive/dvddrive/cddrive/nividagraphicscardgx4000/120ghard drive with windows2000 on it/40g hard drive with ubuntu on it/standared keyboard/labteclaser mouse/pentIII prossesor 1200mgh/ running on the internet with dsl 100kbps/ and I believe that is all of it, so I would really apreaciete if you will help me with this problem , I don't want to loose everythig at this point.
As for what I was doing i was upgrading from the version of ubuntu that was just before this one(upgrading to 8.04) and it was going okay and then it just stoped and this point twards the end and in the terminal window it said this-"Installing new version of config file/ ect/belocs/ios-639.def... en AU.UTF-8...." so at this point I am wondering if something is wrong, oviouslly, as well on what to do for I fear if I reboot my computer that it will crash and i will not be able to recover anythig on eigther file systems. so like i said please help for i am stuck at this point?????????????

thankyou
again
alfofoutofthisworld

ProblemType: Bug
Architecture: i386
Date: Mon Jul 21 04:09:49 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/gnome-system-monitor
Package: gnome-system-monitor 2.22.1-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
LANG=en_US.UTF-8
SHELL=/bin/bash
SourcePackage: gnome-system-monitor
Uname: Linux 2.6.22-15-generic i686

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Homer
Solved:
2008-07-21
Last query:
2008-07-21
Last reply:
2008-07-21
Homer (homer26s) said : #1

the distriution upgrade installer also says that on the progress bar it is at 13 min remaining at the section for installing upgrades..if this helps any?

Homer (homer26s) said : #2

I'm going to take a chance and reboot my computer.. I will be back hopefully to let you know..cross your fingers..k??????
\

Thor K. H. (nitrolinken) said : #3

If it's still installing, do not reboot.

Homer (homer26s) said : #4

no it's not... it's been like this sence 3:00am last night and i have already rebooted just a few min ago?

Homer (homer26s) said : #5

Should i go ahead and try and reinstall 8.04????

Homer (homer26s) said : #6

???

Thor K. H. (nitrolinken) said : #7

That would be a good idea.

Homer (homer26s) said : #8

thamkyou again

cirelle (gcirino) said : #9

I found this in the bugs area and it worked for me

 Izzy wrote on 2008-07-17: (permalink)

I just ran into the same problem a few hours ago. Google brought me to the same sources as quoted above. "Compiling" the collected information, here is a work-around that did it for me (step-by-step - so everybody can solve it until the bug is fixed):

run the dist-upgrade as recommended. If the process hangs at generating locales, taking more than 20min for the first one and still not continuing:

chmod 644 /usr/bin/localedef
killall locale-gen

now the process should continue, but throwing a bunch of errors (simply ignore those). If it still not continues, check whether locale-gen has really been killed (ps aux|grep locale-gen) and repeat "killall locale-gen" until it's gone.

When update-manager is done, don't forget to

chmod 755 /usr/bin/localedef

For me, update-manager seemed to be able to finally solve the issue, there have been no more steps required after the above. But just to be sure:

Reboot to the normal grub option offered (i.e. the latest kernel just installed), but do not yet login graphically. Instead, press Ctrl-Alt-F1 to get a text console. Login there, and run

apt-get dist-upgrade
dpkg --configure -a

As just stated, in my case both were done within a second, simply stating there was nothing to do. Now you can logout here (type "exit" or press Ctrl-D), return to the graphical console (Alt-F7), and login. You are done.

Besides: I was really mad that the dist-upgrade forced me to install OpenOffice. I had it explicitly uninstalled, since it conflicts with StarOffice which I prefer. Luckily, I was able to simply uninstall OO again and there have been no side-effects left as far as I can tell up to now. The dist-upgrade should not just install stuff like that if it was not installed...

Bryan (bjsnp) said : #10

I too had a similar problem. Upgrading from 7.10 to 8.04. Running an HP Pavillion A509.uk. 2.6Ghz celeron, 512 mb ram 40gb HD, with second 20Gb drive on second drive cable. 250 KB/s internet. Previously working great on 7.10. This is my first foray into Linux. No previous Linux experience, although my computer days go back to DOS 3.1. Backed everything up, including Evolution to a USB HD. Just in case, I downloaded an 8.04 install CD from Ubuntu site. Upgrade went well, then an error message (which told me to consider a bug report) that APCID wasn't upgrading properly and probably wouldn't work. using second PC, found a workaround for this on a Forum. Then the same for PulseAudio. Then the same for Gnome Desktop. At 9 minutes remaining, it was configuring locales, "en AU.UTF-8". 20 mins later, sporadic HD activity and clearly hung, although some functionality available on the main system. I pulled the plug (literally) and tried a boot off the ISO image CD. The system hung up. Tried twice more, no joy. Reinstalled 7.10 from CD and all working fine. Reinstalled 8.04 from the CD and all worked fine, all home files and Evolution reconfigured. After 4 hours, all is well. Not sure what I did wrong, or what is weird about my system - any comments?? All seems to be working OK, although I haven't had time to check much yet. Lesson learnt is that backup's are essential on an off-line device. Linux is definitely not for the timid or for a main machine, if my experience is anything to go by, but I stand to be corrected.