need help to get video and sound on ubutu

Asked by Carl on 2008-07-20

Hi im a total biginer with ubuntu and i have 3 questions 1 how do i get the sound to work i cant seem to do it 2 how do i get the video players to play my dvd films and 3 how come when i try to install/run say a program or game(world of warcraft)does nothing happen i just see the cd or game icon on the desk top and the programs wont run when i click on the installer.so if anyone can help me with these problems i would be very grate full.also could u explain in very basic terms as im a compleat noob with computers and this os.cheers :D

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Carl
Solved:
2008-07-27
Last query:
2008-07-27
Last reply:
2008-07-22

This question was reopened

  • 2008-07-21 by Carl
Thor K. H. (nitrolinken) said : #1

No problem.

1. When you say sound, I suppose you mean playing your digital media (music and such). I recommend you take a look at https://help.ubuntu.com/community/RestrictedFormats It'll tell you what you need to do.

2. If you follow the instructions on that page, it should work without further issues.

3. You are most likely trying to install a game that is designed and meant for Windows. However, Ubuntu (linux) is not Windows. To run a Windows application / game in Ubuntu, you'll need to use wine ( http://www.winehq.com ). However, not all games run flawlessly and you might have to tweak settings and google some to get the game you're trying to install working.
Don't worry though, most games do work. If you're very new to Ubuntu and the world of open source, I recommend you take a look at this article, http://linux.oneandoneis2.org/LNW.htm . When you're doing something radical like changing your OS, it's good to be prepared.

Carl (superchocolatecakes) said : #2

Hi i looked at the link u gave me https://help.ubuntu.com/community/RestrictedFormats and i found the terminal code for the sound sudo apt-get install ubuntu-restricted-extras so i entered this applied the ubuntu program and when it finshed downloading is said that it maynot work because i have 2 broken dependancies im guessing this is bad so how would i resolve this .and also a strange thing is that i can hear a very quiet volume coming from my speakers this was before i did anything and its still there i was trying to watch top gear at the tme on bbc i player where the vidio works fine on those sort of sites still minimul or no sound.i also got medibuntu and libdvdcss2 but neither do any thing and i wen to wine d loaded there archive program and wen i try to get it to work i just get a message come up and say not supported.btw ur right i should of been a little cautios before jumping head first into a new os lol.but im not gonna give up ill keep trying with it.Yeah so any idears id be well happy to know .also im a super beginner so as straight forward and as basic as u can get:)cheers

Theodotos Andreou (theodotos) said : #3

Try sudo aptitude install ubuntu-restricted-extras. This could help you resolve these dependencies.

Carl (superchocolatecakes) said : #4

ok i put that in the terminal and this happened wat do i do now?:)

carl@carl-desktop:~$ sudo aptitude install ubuntu-restricted-extras
sudo: unable to resolve host carl-desktop
[sudo] password for carl:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Initialising package states... Done
Writing extended state information... Done
Building tag database... Done
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initialising package states... Done
Building tag database... Done
carl@carl-desktop:~$

Carl (superchocolatecakes) said : #5

no sound or video are working still.and i cant load any games or dvd films?any idears

Theodotos Andreou (theodotos) said : #6

Try again to install the ubuntu-restricted-extras and paste any errors here:

 sudo aptitude install ubuntu-restricted-extras

Carl (superchocolatecakes) said : #7

ok i put into terminal again and if u see the second line below it says sudo: unable to resolve host carl-desktop does this mean anything.im not sure what i am ment to do after i put this into terminal the terminal i thought i would just be able to play films straight away but it seems to make no diference to my problem. when i insert the film dvd it says on the movie player (an error occurred could not read from recorce).the sound is no different i have no idear what to do to get it to work.

carl@carl-desktop:~$ sudo aptitude install ubuntu-restricted-extras
sudo: unable to resolve host carl-desktop
[sudo] password for carl:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initialising package states... Done
Building tag database... Done
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initialising package states... Done
Building tag database... Done
carl@carl-desktop:~$

Theodotos Andreou (theodotos) said : #8

This error message is not the cause of your problem. To resolve it just add the line:

 127.0.0.1 carl-desktop

in "/etc/hosts"

Now try to use this command instead :

  sudo apt-get install ubuntu-restricted-extras

and give me any errors it might have.

Carl (superchocolatecakes) said : #9

theodotos andreou could we chat on msn it might be easier my email is <email address hidden>:)cheers for trying to help me

Carl (superchocolatecakes) said : #10

this is what it says when i enter sudo apt-get install ubuntu-restricted-extras.btw the 127.0.0.1 carl-desktop do i type this in terminal on its own or add it to some thing im unsure wat u meant?

carl@carl-desktop:~$ sudo apt-get install ubuntu-restricted-extras
sudo: unable to resolve host carl-desktop
[sudo] password for carl:
Reading package lists... Done
Building dependency tree
Reading state information... Done
ubuntu-restricted-extras is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
carl@carl-desktop:~$

Thor K. H. (nitrolinken) said : #11

He means that you could open a terminal and do
sudo gedit /etc/hosts

and then add the line to the file.

However, have you tried opening the volume mixer from the panel and checking that none of the other controls / units are muted?

Carl (superchocolatecakes) said : #12

so wat do i type in terminal im confused?no units are muted did u mean for me to go into the open volume contol panel as i dont know were the volume mixer is?

Carl (superchocolatecakes) said : #13

i think im typing this in the terminal wrong?

carl@carl-desktop:~$ sudo gedit /etc/hosts 127.0.0.1 carl-desktop
sudo: unable to resolve host carl-desktop

Thor K. H. (nitrolinken) said : #14

You type "sudo gedit /etc/hosts" in the terminal, then paste the line provided into the document.

Regarding the sound, yes. Open the volume mixer by right clicking the speaker in your upper right corner. Then the volume control panel.

Carl (superchocolatecakes) said : #15

i have terned everything up to max in the volume control panel and i still get no sound?.i typed in sudo gedit /etc/hosts in the terminal and this poped up in another screen

127.0.0.1 localhost
127.0.1.1 carl-desktop.The Hunger

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

i must of typed it wrong last time what do i do now?
and i dont understand where i meant to type 127.0.0.1 carl-desktop
im sorry for being dum im just a super noob with computers and this os

Thor K. H. (nitrolinken) said : #16

Remove 127.0.1.1 carl-desktop.The Hunger and replace it with 127.0.1.1 carl-desktop

Carl (superchocolatecakes) said : #17

ok:)

Carl (superchocolatecakes) said : #18

like this do u mean ive taken out the hunger part:).so whats next Thor?

127.0.0.1 localhost
127.0.1.1 carl-desktop

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

Thor K. H. (nitrolinken) said : #19

Yes, that way.

Regarding your sound, take a look at this link.
https://wiki.ubuntu.com/DebuggingSoundProblems

Carl (superchocolatecakes) said : #20

i got this come up on the terminal after putting in gnome-alsamixer

** (gnome-alsamixer:15283): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Input Source"!

** (gnome-alsamixer:15283): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Input Source"!

then as this message apeared in the terminal page above.And at the same time a program called Gnome alsa mixer pops up i check in this program that everything is unmuted
and then sut the terminal page that had this message,doing this shuts the down. but i came across this other page when following the instructions which i totally dont understand
see below.

─────────────────[AlsaMixer v1.0.15 (Press Escape to quit)]──────────────────┐
│ Card: HDA VIA VT82xx │
│ Chip: Realtek ALC888 │
│ View: [Playback] Capture All │
│ Item: PCM [dB gain=0.00, 0.00] │
│ │
│ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ ├──┤ ┌──┐ └──┘ ├──┤ ├──┤ └──┘ ├──┤ ├──┤ │
│ │OO│ │OO│ │OO│ │OO│ │OO│ │OO│ │
│ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ │
│ 100 100<>100 100<>100 100<>100 100<>100 100<>100 100 │
│ Master Headphon < PCM > Front Front Mi Front Mi Surround Center

also in the instructions to check the sound i found this it doesnt make scence to me. see below

Also check that your switches are set correctly - for instance that if you use the analog output
the analog switch is set ON or that the digital or S/PDIF switch is set OFF.
You can select which tracks/switches are visible in Volume Control (see above) under Edit->Preferences.

so anyway i keep trying to follow the instructions and it tells me to enter this next into the terminal

cat /proc/asound/cards:-

and this comes up below does this mean anything?

carl@carl-desktop:~$ cat /proc/asound/cards
 0 [VT82xx ]: HDA-Intel - HDA VIA VT82xx
                      HDA VIA VT82xx at 0xbfffc000 irq 22
 1 [SAA7134 ]: SAA7134 - SAA7134
                      saa7133[0] at 0xdfffe000 irq 22
carl@carl-desktop:~$

and then the next bit of terminal input is this

options snd-usb-audio index=1

which gives me this

carl@carl-desktop:~$ options snd-usb-audio index=1
bash: options: command not found
carl@carl-desktop:~$

i get to this point and i think my brain has melted what does all this mean and am i any closer to sorting out my sound.oh i dont know if this helps but when
i first installed ubuntu and still now i can hear super queit sound comming from my speakers .i found this out while watching some top gear on bbc i player
but i cant get the sound to tern up in anyway and the only way i can hear the sound is by putting my ear right up to the speaker?im so lost please help me:)

Thor K. H. (nitrolinken) said : #21

With your last sentence I'm pretty sure the problems lies within your wires.

Check that your speakers are connected to a green circle input, not the line input. The reason you hear a small sound is because your speakers aren't connected to the correct plug. Plug it in at the correct spot and your sound issue should be solved.

Carl (superchocolatecakes) said : #22

omg guess what lol u were right the sound come out of my speakers and my monitor now :)you are a star.i get a lot of his anything i can do to sort that out?.and also how do i solve my playing dvd problem?

Carl (superchocolatecakes) said : #23

omg guess what lol u were right the sound come out of my speakers and my monitor now :)you are a star.i get a lot of his anything i can do to sort that out?.and also how do i solve my playing dvd problem?

Thor K. H. (nitrolinken) said : #24

Regarding video, first add this repository:
https://help.ubuntu.com/community/Medibuntu

Then install VLC media player and libdvdcss2-
sudo apt-get install vlc libdvdcss2

It might just do the trick.

Carl (superchocolatecakes) said : #25

i did these in the terminal is this all correct

carl@carl-desktop:~$ sudo wget http://www.medibuntu.org/sources.list.d/hardy.list -O /etc/apt/sources.list.d/medibuntu.list
sudo: unable to resolve host carl-desktop
[sudo] password for carl:
--16:16:58-- http://www.medibuntu.org/sources.list.d/hardy.list
           => `/etc/apt/sources.list.d/medibuntu.list'
Resolving www.medibuntu.org... 87.98.242.110
Connecting to www.medibuntu.org|87.98.242.110|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 226 [text/plain]

100%[====================================>] 226 --.--K/s

16:16:58 (38.19 MB/s) - `/etc/apt/sources.list.d/medibuntu.list' saved [226/226]

carl@carl-desktop:~$

and

--16:17:49-- http://packages.medibuntu.org/pool/free/libd/libdvdcss/libdvdcss2_1.2.9-2medibuntu4_i386.deb
           => `libdvdcss2_1.2.9-2medibuntu4_i386.deb'
Resolving packages.medibuntu.org...
88.191.30.43, 91.121.38.148, 213.186.45.139
Connecting to packages.medibuntu.org|88.191.30.43|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 36,270 (35K) [application/octet-stream]

100%[====================================>] 36,270 103.12K/s

16:17:51 (102.94 KB/s) - `libdvdcss2_1.2.9-2medibuntu4_i386.deb' saved [36270/36270]

carl@carl-desktop:~$ sudo dpkg -i libdvdcss2_1.2.9-2medibuntu4_i386.deb
sudo: unable to resolve host carl-desktop
Selecting previously deselected package libdvdcss2.
(Reading database ... 123179 files and directories currently installed.)
Unpacking libdvdcss2 (from libdvdcss2_1.2.9-2medibuntu4_i386.deb) ...
Setting up libdvdcss2 (1.2.9-2medibuntu4) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place
carl@carl-desktop:~$

and

carl@carl-desktop:~$ sudo apt-get install libdvdcss2
sudo: unable to resolve host carl-desktop
Reading package lists... Done
Building dependency tree
Reading state information... Done
libdvdcss2 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
carl@carl-desktop:~$

and

carl@carl-desktop:~$ libdvdcss2-
bash: libdvdcss2-: command not found
carl@carl-desktop:~$ sudo apt-get install vlc libdvdcss2
sudo: unable to resolve host carl-desktop
[sudo] password for carl:
Reading package lists... Done
Building dependency tree
Reading state information... Done
vlc is already the newest version.
libdvdcss2 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
carl@carl-desktop:~$

and

carl@carl-desktop:~$ wget -c http://packages.medibuntu.org/pool/non-free/w/w32codecs/w32codecs_20071007-0medibuntu2_i386.deb
--16:21:41-- http://packages.medibuntu.org/pool/non-free/w/w32codecs/w32codecs_20071007-0medibuntu2_i386.deb
           => `w32codecs_20071007-0medibuntu2_i386.deb'
Resolving packages.medibuntu.org... 88.191.30.43, 91.121.38.148, 213.186.45.139
Connecting to packages.medibuntu.org|88.191.30.43|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 14,283,118 (14M) [application/octet-stream]

100%[====================================>] 14,283,118 114.67K/s ETA 00:00

16:23:46 (112.20 KB/s) - `w32codecs_20071007-0medibuntu2_i386.deb' saved [14283118/14283118]

carl@carl-desktop:~$ sudo dpkg -i w32codecs_20071007-0medibuntu2_i386.deb

i also have vlc media player now whats next thor

Thor K. H. (nitrolinken) said : #26

Now you should be able to play DVDs with vlc. Applications -> Sound & Image -> VLC media player

Carl (superchocolatecakes) said : #27

hi i go into applications but i dont have the option to chose Sound & Image were do i find it all i have that is close to that option is sound and video.if thats the one u mean i then have vlc at the bottom i open it and then were do i go in vlc to get the dvd that is in the drive to work?

Carl (superchocolatecakes) said : #28

oh i got it working cool dunno how i did it .ok cool last question now .thanks by the way thor u are the best dude.how do i get world of warcraft to run/install on linux .once i can do this i think everthing will be cool?

Carl (superchocolatecakes) said : #29

oh i got it working cool dunno how i did it .ok cool last question now .thanks by the way thor u are the best dude.how do i get world of warcraft to run/install on linux .once i can do this i think everthing will be cool?

Carl (superchocolatecakes) said : #31

 vlc aint great for legit films seems not so great quality as media player could provide but im happy either way linux is sooo much cooler.im not really bothered but if there is a way to get vlc made as my default or to some how get any sort of disk i want to use /run/install to run automatically in vlc or which ever program needed for the media i want to run from disk that would be awsome as well.i used vlc in the past for dogy films so i like the program so if u have no solution to the above that ok.:D

Carl (superchocolatecakes) said : #32

sorry about this im being greaddy with ur knowledge uve been such a GREAT help so far wow is installing as i type this:D.yeah ii was wondering u know that cool cube program i think its called compix or comiz how do i get that to work as is sooo smart.i think Linux wipes the floor with previous OS ive used.and also how can i get rid of the hissing on my audio nothing major but it really anoying?

Theodotos Andreou (theodotos) said : #33

Install the Advanced Deskot Effects Settings. If you are using kde it can be more tricky to configure.

Carl (superchocolatecakes) said : #34

ok i installed the Advanced Deskot Effects how do i get it to run now?
:)

Thor K. H. (nitrolinken) said : #35

Generally, just open System -> User settings (or something along that line, I don't use the english localization) -> Appearance

Then select the "Visual effects" tab and activate it. The advanced desktop effects settings will help you tweak it to a higher level.

Theodotos Andreou (theodotos) said : #36

It's in the menu. Sellect ftom System->Preferences in Gnome or Settings menu in KDE. Select the features you want and close it

Carl (superchocolatecakes) said : #37

i went into the aperance prefferences menu and the best i can chose from the visual effects menu is extra which works well .lol like the wobbly windows.but no compix option in there wat have i done wrong?.also i have no gnome or settings option and or the Kde option so that maybe why im not sure please get back to me uve all be awsome so far:D

Thor K. H. (nitrolinken) said : #38

What you're using there IS compiz.

You can find the advanced settings for compiz by going to System -> User settings -> Advanced Desktop Effects Settings.

If you can't find it, you can always type "ccsm" into the terminal or press Alt+F2 and enter "ccsm" into the run field.

Carl (superchocolatecakes) said : #39

all done ta thor again:D