how to change 1920x1200 61Hz in desktop from kernel

Asked by simonsilvio

Once a year i try a Linux distro and only end up getting frustrated and forgetting the trials i faced until another year goes by.

I just downloaded Ubuntu 8.4.1 and when trying to boot from the CD to sample the OS all of those menus look fine. But once I enter the desktop my monitor freezes because it's getting a refresh rate greater than 60Hz which it can't handle at its native resolution of 1920x1200. On another computer whose native resolution is 1280x1024 I was able to catch the fact that the desktop was defaulting to the rather odd refresh rate of 61Hz.

What boot parameters can I set to keep the refresh rate at 60Hz for 1920x1200 or would it be easier to boot into a different resolution (and what would that parameter be?)?



Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Bhavani Shankar (bhavi) said :


Please try to press CTRL+ALT+"+" and/or CTRL+ALT+"-" to dynamically change video frequency
or press CTRL+ALT+BKSPACE to restart graphics layer.

Reconfiguring your xserver-xorg may help you.

A) If you can view graphics Gnome desktop

Please open a Terminal from the menu Applications->Accessories->Terminal
and jump to step C

B) If you cannot view graphics Gnome desktop

Please press CTRL+ALT+F2 and make login with your user and password
and go on to step C


To make a backup copy of your actual /etc/X11/xorg.conf type:

cd /etc/X11
sudo cp xorg.conf xorg.conf.bak

give your user password when requested, you don't see nothing when you type it, then press enter.

Then try to reconfigure your xserver-xorg

sudo dpkg-reconfigure xserver-xorg

answer to the simple questions, then restart the pc.

If something goes wrong you can restore the saved copy of your old configuration, open a terminal or login to a virtual terminal by pressing ctrl+alt+F2 and type:

cd /etc/X11
sudo cp xorg.conf.bak xorg.conf

and restart the pc, type:

sudo reboot

Hope it helps

Bhavani Shankar.

Revision history for this message
Harvey Muller (hlmuller) said :


I am checking to see if the information previously provided resolved your question. If so, please return to Launchpad and mark the question Solved.



Revision history for this message
simonsilvio (ssdietsch) said :

When pressing ctrl-alt-+ at just the right moment before the desktop finishes loading the screen zooms rather than changes frequency. Pressing ctrl-alt-+, -, or F2 wouldn't change anything while in the desktop, and the boot image I downloaded from the Ubuntu torrent mirror offers no login options nor access to the xorg.conf file.

Going through the install option continued the same freezing process. There also exists the simple possibility of a hardware conflict possibly with my nVidia 7800 GT graphics card where different drivers are being loaded between accessing the boot options screen (works fine) and entering the desktop (freezes up immediately before finishing loading the toolbars).

Constantly rebooting to an incompatible OS tested my patience a bit too much, so I resolved to simply install VMware and am having a great time testing out Ubuntu in that environment.