Simple Makefiles with source codes and result

Asked by nigelclegg

 Please help. I#m new in unbuntu, but I tried for days and I#m now frustrtated about what I could find from Google about simple makefiles like 1) , makefiles by example (I wrote all 4 c-files as a new directory, copied this into "terminal". Yet there were problems with main, above all "terminal" does not accept a TAB ); 2) (An Introduction to GCC-for the GNU-compilers gcc and g++, by B. J. Gough, threre are no defined source files for main.c and hello_fn.c . I tried to put the program into "terminal", again TAB does not work). In either case I would not find a control about the results, maybe in case of 2) with ./main which gives Hello, world!

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Bhavani Shankar (bhavi) said :
Revision history for this message
Harvey Muller (hlmuller) said :


The answer is in the text you posted! Your rfkill switch has disabled the wifi. Flip the switch!

If this resolves your question, please mark the question Solved.



Revision history for this message
nigelclegg (nigeldclegg) said :

I've tried so many things I think I've destroyed it all and need to re-install and start from scratch. Also, when I upgraded, my sound didn't work either, and it seems to not recognise duo chips as it's running on one only and keeps freezing. I'm super miffed. Any last help b4 I completely re-install?

Oh, and thanks!!!

Revision history for this message
Harvey Muller (hlmuller) said :


I remind you that the extract of the log you provided shows:

    [ 56.100423] iwl3945: Radio disabled by HW RF Kill switch

This means you have a switch that controls the wifi, and it is turned off. If you cannot locate it on the exterior of your laptop, you can probably disable the switch in your BIOS. If you decide to disable the wifi switch in BIOS, you'll have to figure that out on your own. If you don't have a manual from the manufacturer, you can probably get one from their website.

This question is specific to the wireless issue, any additional questions should be created separately, one per question.

Please return to Launchpad and mark this question Solved if this resolves your question.



Revision history for this message
nigelclegg (nigeldclegg) said :


Sorry for taking so long Harvey. Yes the switch was activated but made no difference to the output.

Thanks for your help but I got so frustrated after spending nearly a week to solve this, I backed my files up and did a complete fresh re-install of Hardy and the wireless now works although the light doesn't work but I'm not too bothered, just pleased to be back on again.

Thanks for your help anyway guys

Revision history for this message
ansar (ansar-thehelloindia) said :

this is what i see for

ishw -c network

*-network UNCLAIMED
       description: Network controller
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:0b:00.0
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: cap_list
       configuration: latency=0