After installing ubuntu, Missing MBR helper error

Asked by RacerA1

I installed ubuntu 8.04 using Wubi 8.04 to partitioned 50, gig hard drive 20 gigs formatted(ntfs) to run windows xp and 30 gigs formatted (fat32) to run ubuntu on a gigabyte amd1500. I installed from xp without a cd and the install formatted drive d: and appeared to finish with no problem. after reboot to ubuntu i get "error not found missing MBR helper" message. i can reboot back to xp ok but i am wondering if there is something i did wrong. I tried this once before on two separate drives using grub as well and made it to grub command prompt and dont know where to go from that point so i rebooted to xp and my xp failed to load saying unable to locate autochk.exe and after triing to repair it with the xp disk it said my partition was inactive. now although that is a separate question, repair advice on either question would be a blessing because as we alol know with "Microsoft" after a couple intalles of xp the install wont activate and my only now active version of xp is on an inactive drive! Thanks for any advice in advance! Signed: "Praying to get of Microsoft products"

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Bhavani Shankar (bhavi) said :


The problem seems to be a direct media error. try completely formatting the Hard Disk, clearing the Master Boot Record by booting from the Windows XP install CD, going into recovery console and typing in "fixmbr" and then re-install Ubuntu


Bhavani Shankar.

Revision history for this message
Harvey Muller (hlmuller) said :


I am checking to see if the information provided previously resolved your question. If so, please mark this question Solved.



Can you help with this problem?

Provide an answer of your own, or ask RacerA1 for more information if necessary.

To post a message you must log in.