S3 ProSavage DDR video driver

Asked by jenny on 2008-07-15

I am trying to install ubuntu 8.04 on a computer with S3 ProSavage DDR integrated video. Ubuntu can't detect the video and I got to the manual configuration screen. I still can't find the right driver on the pick list. Is there a ubuntu driver for this or which driver should I use? If I use the vesa generic driver I can only get 800x600 resolution and my monitor optimal resolution is 1024x782. Also seems like if I select any S3 driver and click on test, the system would hangs. This is the first time I try ubuntu and I can't get 1024 display on 2 computers that I tried. The other computer is on Nvidia video. Thanks.

Question information

Portuguese Edit question
Ubuntu xserver-xorg-driver-s3 Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

About the Nvidia PC, did you install the Nvidia driver through Hardware Drivers in System>Administration>Hardware Drivers?

jenny (jlee-jny) said : #2

Yes. I enabled the propriety from Hardware Drivers but I still wasn't able to change the screen resolution.

jenny (jlee-jny) said : #3

I figured it out on the S3 ProSavageDDR GPU. On Ubunto video configuration, I picked S3 Savage driver then selected my monitor and resolution and refresh rate then save it. Upon reboot I got the resolution that I wanted. But now I am having problem instilling some of the upgrade.

jacobS (jacsalomon) said : #4

You problem is not comun:

xorg.conf for S3 prosavage DDR:

Section "Device"
 Identifier "S3 Inc. VT8375 [ProSavage8 KM266/KL266]"
 Boardname "savage"
 Busid "PCI:1:0:0"
 Driver "savage"
 Screen 0

Send information of:
$ cat /var/log/Xorg.0.log

ovicornea (ovi-cornea) said : #5

Please, I need help!

I also have S3 ProSavage DDR video card and I can't get Ubuntu to install. It stops at the place where I have to choose resolution. It says: "Ubuntu is running in low-graphics mode". If I press on Continue, the system hangs. If I try to configure it, i don't know what to choose. Does it really matter the screen setting (in configuration window) or just the graphic card's?

jenny (jlee-jny) said : #6

You need to run configuration. See previous posting on which driver to select or how to get the configuration button if you don't see it any more. After you set your selection, make sure you save it.