Mail Listing Server

Asked by udaykiranchapala on 2008-07-14

Sir, I am a Windows user.
i have recently switched to Ubuntu for my requirement of installing Sympa (Mailing list Server)
which has the following prerequisites.

pre requisites:
____________

->OS: * Linux (various distributions)
* FreeBSD 2.2.x and 3.x
* Digital Unix 4.x
* Solaris 2.5 and 2.6
* AIX 4.x
* HP-UX 10.20
->OS requirements: XPG4-standard NLS extensions.
( The availability ofgencat command as well as catgets(3) and catopen(3)
functions in the OS symbolizes the existence of these extensions.)
->recent release of sendmail MTA ( atleast 8.9.x ) or postfix or qmail.

->ANSI C compiler ( gcc compiler )

->DB Berkeley module (already installed on most UNIX systems).

->Pearl 5.004_03 or later ( generally comes by default )

->CPAN (Comprehensive Perl Archive Network) modules
* DB_File (>= v. 1.50)
* Msgcat
* MD5
* MailTools (version 1.13 and upper)
* MIME-tools (may require IO/Stringy)
* MIME-Base64

For the storage and retrival of data to & from RDBMS

-> DBI (DataBase Interface)
->DBD (DataBase Driver) related to your RDBMS (e.g. Msql-Mysql-modules for
MySQL)

Net::LDAP (perlldap). [as per requirement]

I have Ubuntu Desktop version
I am unable to check for the required pearl modules
and help me in setting up this Server.
Any kind of information & guidance would be appreciated.

Thanks in Advance
UdayKiran

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Rafik Ouerchefani
Solved:
2008-07-16
Last query:
2008-07-16
Last reply:
2008-07-14
Best Rafik Ouerchefani (rafik) said : #1

Hello,

I found the package in Ubuntu repos : http://packages.ubuntu.com/uk/hardy/mail/sympa
All you need to install Sympa is going in menu System > Administration > Synaptic Package manager
Search for Sympa and mark it for installation.
Apply changes and... that's all.

-Rafik.

Dear Sir, I have installed a fresh copy of the latest version of Ubuntu ie 8.04 LTS.

But when i was installing Sympa, it gave me the following error.

" Not all changes and updates succeeded. For further details of the failure, please expand the 'terminal' below.

E: sympa: subprocess post-installation script returned error exit status 2. "

eagerly waiting for your reply.

Thanks in advance,
UdayKiran

Thank you sir thank you very much for the information you've provided.
I shall always be grateful to you for this help.
Thanks again

Thanks Rafik Ouerchefani, that solved my question.