upgrade to glib2-2 in hardy?

Asked by Jeff Patterson

I'm trying to build the latest rhythmbox from source to get it to play with the latest coherence uPnP plugin. The automake failes the glib-gettext dependency test (glib-gettext >= 2.2.0). If I download glib2.2 and build/install it from the source, am I likely to cause other problems? Why is Ubuntu still at glib 2.0?


Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Benjamin Drung
Last query:
Last reply:
Revision history for this message
Benjamin Drung (bdrung) said :

I tried to reproduce your problem. I downloaded rhythmbox-0.10.1 (which is the newest). First I installed all build dependencies of rhythmbox with: "sudo apt-get build-dep rhythmbox". Then I run ./configure without problems, also running automake (only some warnings). Can you post your config.log file?

Revision history for this message
Hans Spaans (hspaans) said :

When you run the Hardy release then run the following command:

# sudo apt-get install python-coherence

You can then enable the uPnP plugin in Rhythmbox 0.11.5 that is being shipped with Hardy.

Revision history for this message
Jeff Patterson (jpat) said :

Thanks for the reply but I had already got the uPnP working with the hardy release. Unfortunately it is lame, the interface only shows a huge list of songs, no album, artist genre sorting. The new release of coherence is supposed to be much more full featured.

I figured out that I needed the glib2-dev libraries (and a bunch of other stuff). When I tried to build-dep I get the following error: "You must put some 'source' URIs in your sources.list" I don't know how to do this. I manually installed the stuff that make was complaining about until I finally got it to compile. But when I run it with the uPnP plug-in enabled, it does not detect my media server (twonky). Were you able to connect to a uPnP server after you compiled?


Revision history for this message
Best Benjamin Drung (bdrung) said :

To add source URIs in your sources.list: Open Software Sources -> Ubuntu Software -> Check Source Code. Then click on close and then on reload.

I only tried to compile rhytmbox. I did not test, if it works. I never used uPnP.

Revision history for this message
Jeff Patterson (jpat) said :


This solved my compile problems although I did have to use the --prefix=/usr option for the install to work properly. If I used the default prefix (/usr/local) , rhythmbox couldn't find its so libs in /usr/lib. This probably could be solved with an environment variable setting but I thought it better to stick with the ubuntu locations.

With a clean compile, rb still does not detect my uPnP server. I think there is an issue in the latest coherence release.

Thanks for your help!