problem with suspend and hibernate in ubuntu 8.04

Asked by arnorhe on 2008-07-11

Hi

I'm rather new with Linux and what I've seen I like very much. The only problem I have had is this problem with suspend and hibernate. When I suspend my computer it goes normally to suspend but when I resume from suspend there is just a black screen and nothing happens. My friend had the same problem and it works for him to press ctrl+alt f8 and then alt+f7. I've tried that many times but nothing works. He is using computer from HP, don't know what type.

I've been looking a lot for a solution for this problem but I have not found anything. I've been checking some forums including this =>http://ubuntuforums.org/showthread.php?t=786311&highlight=suspend&page=4 but none of these advises work including this =>http://blog.vaxius.net/?p=43

When I hibernate my computer it starts hibernating but it never turns of, there is just a flashing white mark in the upper left corner of the screen and nothing happens.

In both of these problems I have to shut down the computer manually and restart it.

I'm using ubuntu 8.04 - the hardy heron - released in april 2008.
My computer is fujitsu siemens E8020D AND compaq presario X6000

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Harvey Muller
Solved:
2008-07-18
Last query:
2008-07-18
Last reply:
2008-07-18
Harvey Muller (hlmuller) said : #1

What graphics hardware is installed? You can run the following in a terminal to find out if you do not know:

    $ lspci | grep VGA

Thanks!

Harvey

arnorhe (arnoheid) said : #2

This is in the Fujitsu siemens
01:00.0 VGA compatible controller: ATI Technologies Inc M24 1P [Radeon Mobility X600]

Harvey Muller (hlmuller) said : #3

arnorhe,

I am familiar with systems based on nvidia graphics and the problems they cause with suspend and hibernate. But not so much with ATI systems.

Sorry I cannot be of much help. Please make a new comment to change the status of the question to open, so others may chime in.

Thanks!

Harvey

p.s. The solution with nvidia based graphics is to use nvidia-glx-new, the restricted binary driver, and to make modifications to acpi-support. I'm not sure if that will help in your case though.

arnorhe (arnoheid) said : #4

ok, thanks anyway

This is a bug with Ubuntu 8.04. I linked your question to the bug.

arnorhe (arnoheid) said : #6

ok, thanks for that. But is the answer to my question somewhere here ? => https://bugs.launchpad.net/bugs/199088

This is a very long list of solutions that may possibly work but not for sure...

why is this bug not just fixed as a update in ubuntu 8.04? maybe someone is working on it, I hope so

They are working on it, because it effects everyone who uses suspend hibernate etc

Best Harvey Muller (hlmuller) said : #8

arnorhe,

Shane has demonstrated that this is a bug that is being worked on.

There is nothing more to do than wait, or provide additional information to the bug if it is not already contained there.

Please mark the question Solved.

Thanks!

Harvey

arnorhe (arnoheid) said : #9

Thanks Harvey Muller, that solved my question.