Error playing audio stream

Asked by Andy Ruddock on 2008-07-11

Trying to listen to BBC Radio 1 stream, I use the command :
# totem http://www.bbc.co.uk/radio1/realaudio/media/r1live.ram

I get this error :
** Message: Error: Could not write to resource.
gstrtspsrc.c(3157): gst_rtspsrc_try_send (): /play/source:
Could not send message. (System error: Connection refused)

This works on my home machine so I know it's possible. I have realplayer 11 for Linux installed and that plays the stream fine.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Andy Ruddock
Solved:
2008-07-11
Last query:
2008-07-11
Last reply:
2008-07-11
Bhavani Shankar (bhavi) said : #1

Hello

the totem gstreamer plugin can play bbc radio, you dont need realplayer AFAIK...
there is a bug in the current hardy version that gives garbled sound https://bugs.launchpad.net/ubuntu/+source/totem/+bug/217301 and its already fixed (Please download the packages below and install them)

you can download it from:

http://launchpadlibrarian.net/14654991/gstreamer0.10-plugins-ugly_0.10.7.4-1_i386.deb
http://launchpadlibrarian.net/14656337/gstreamer0.10-plugins-ugly_0.10.7.4-1_amd64.deb (for 64 bit)

Regards

Bhavani Shankar.

Andy Ruddock (andy-ruddock) said : #2

Downloaded and installed the plugins, but I'm still getting the same error.

Andy Ruddock (andy-ruddock) said : #3

I just synced the packages from the machine on which this works to the machine on which it doesn't.
It isn't down to a missing package, but still doesn't work :(

At a terminal, type in:
sudo apt-get install ubuntu-restricted-extras

If this doesn't work, add the medibuntu: http://bapoumba.wordpress.com/2008/05/01/medibuntu-non-free-codecs-for-hardy/
And install the package w32codecs

Andy Ruddock (andy-ruddock) said : #5

I'm looking at the strace for this and I see

write(21, "OPTIONS rtsp://rmlive.bbc.co.uk/"..., 551) = -1 ECONNREFUSED (Connection refused)

so I think this could be a firewall problem.
If I do netstat then I see :

Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 myhost:59664 rm29.rbsov.bbc.co.u:www ESTABLISHED
tcp 0 0 myhost:37210 rm29.rbsov.bbc.co.u:www ESTABLISHED

which indicates that the realplayer is using http for transport.
In fact, if I disable the use of http for rtsp then realplayer fails also.
As this machine is a laptop I'll take it home to confirm this.

So, is it possible to configure the gstreamer plugins to use http for rtsp transport?

Andy Ruddock (andy-ruddock) said : #6

Confirmed that this is indeed the problem. just need to get rtsp over http. Thanks for your help.