my synaptic package manager won't download updates. It stays on 1 of 228 for about an hour and doesn't move.

Asked by ngodfather114 on 2008-07-09

I have a new dell insirion 1420 with ubuntu 7.10 pre-installed. It worked great. I upgraded to 8.04. Worked great. I think I played around too much with it and it started acting up so bad that I had to start over again. So I went back to it's 7.10. I did it using the official disk that dell gave me. Now naturally there are updates. My system says updates are avalable so I click it eneter my password and hit install. it starts to work then freezes up. It says 228 updates can be installed but it freezes up one 1 of 228. After an hour it still says the same. I closed it out and tried from the synaptic manager and again it froze on 1 0f 228. I clicked on the details box and there was a list with the word "fail" next to each line. Why is it failing and freezing? I just want my system back to normal again, running smooth and updated. Please help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Bhavani Shankar
Solved:
2008-07-10
Last query:
2008-07-10
Last reply:
2008-07-10
Rafik Ouerchefani (rafik) said : #1

Hello,

Try to change your server in :
System =>Administration =>Software Sources : Tab: "Ubuntu Software" => Download from "....."
Choose another one.

Then, in a terminal session type :

sudo apt-get update && sudo apt-get upgrade

Best Bhavani Shankar (bhavi) said : #2

Hello

Hmm.. Might be a transient... Wait for some time OR

Click System > Administration > Software Sources
Click the Download From menu and choose other
Click the Select Best Server button and wait till it finds one.
Click Choose Server
Run the update manager again.

Regards

Bhavani Shankar.

ngodfather114 (ngodfather114) said : #3

Thanks guys problem solved. Now it gave me the option to upgrade to 8.04. I did it and back to normal. Thanks again.

ngodfather114 (ngodfather114) said : #4

Thanks Bhavani Shankar, that solved my question.

Wendy Kirby (ofmineheart) said : #5

I have just started using Ubuntu. I have 30 updates waiting to be installed. I click on install updates I do everything I am told to do such as entering a password. The computer says that it is building data structures but after that nothing happens. Can you help?