BitTorrent Help

Asked by skooter on 2008-07-07

i have a problem when i try to download torrent files, when ever i try to i get an error messages that reads - ".torrent could not be opened, because the associated helper application does not exist. Change the association in your preferences." i have looked under preferences and i cannot find what i have to do to change it, i am using the default transmission bit torrent client, and i running ubuntu 8.04, somebody please help me.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
skooter
Solved:
2008-07-09
Last query:
2008-07-09
Last reply:
2008-07-09
Rafik Ouerchefani (rafik) said : #1

Hello,

Right click on the .torrent file => "Properties" => "Open With"
Click on the radio button beside "Transmission BitTorrent Client"

That's all.

-Rafik

skooter (jjmcquaid) said : #2

thats still not working it doesnt give me an "open with option", and i still get the same error message ".torrent could not be opened, because the associated helper application does not exist. Change the association in your preferences."

Steven Rose (steveydoteu) said : #3

There will be a context menu "Open With" put your mouse over it and it will open, then click "Open with other application"

Steven Rose (steveydoteu) said : #4

Or under properties there is a tab entitled open with.

skooter (jjmcquaid) said : #5

no, thats still not working, i have firefox and when i click on the torrent link i get these options 1. retry, 2. go to download page, 3. copy download link, 4. select all, and 5. remove, and when i do that on the torrent link i get one page that just describes the link properties, no tabs, so i dont what else to do.

skooter (jjmcquaid) said : #6

some one help me!

Steven Rose (steveydoteu) said : #7

If you had told us you were clicking links in the first place it may have helped us provide a solution more appropriate. Also informing us which browser as well will be useful. Perhaps even which torrent client you are trying to use. With a lack of information help can be very hard to provide!

I can give instructions for Firefox 3, but if you are using different, then I am afraid they will be useless.

Edit > Preferences

There are a number of sections on the preferences window, the fourth being "Applications" click it.

Here you will find the associations for a number of file types. The search box will aid in finding the one for BitTorrent seed files (*.torrent).

Select it and you will notice the right hand column provides a drop down menu of options. Select "Use other.." and browse to /usr/bin/ and locate the application you use for torrents.

This should solve the issue, you may need to restart Firefox first though.

Failing this you are always able to download the files to your computer and then open them in a torrent application.

One final point, patience is a virtue, you did not even wait 24 hours before replying again, this will send unnecessary emails to my inbox, and many other peoples. A lot of us do not just use this site and this site alone, nor do we sit at our computers all day every day. Before spamming the questions, or anything else for that matter with impatient messages, take a moment to consider this. As a general rule of thumb, wait 24-48 hours before "bumping" a topic for an answer. Being more polite about it rather than demanding as well would be a good idea, excessive punctuation or capitals make no difference either, not saying you did either of these but still. A lot of people are more likely to ignore someone whom spams or capitalizes summaries or is overly impatient. :)

skooter (jjmcquaid) said : #8

thanks a lot, that really helped, sorry i didnt provide the necessary information before, i thought i mentioned that stuff. sorry about everything, and thanks a lot.