Can't play videos

Asked by Maya Cain

I recently upgraded to 7.10 from 7.04 in which I could play both audio and video of both CD and downloaded music and videos. With 7.10 I can't. If I install ubuntu-restricted-extras I have picture but no sound and if I uninstall that package I have nothing on downloaded videos but I do have sound on CDs and dowloaded music. The message I get is "Video codec 'XviD' is not handled. You might need to install additional plugins to be able to play some types of movies" or "Video codec 'Microsoft MPEG-4 v3' is not handled. You ...." I am not a techie so I need plain English talk on how to fix it. Help! And thanks in advance.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best ajmal_82 (ajmal-82) said :

Goto google add medibuntu repository and sevenseas deb support.this is by going to system>>adminstration>>software sources and add some lines of html links to that website,google search medibuntu repository then follow instructions.i suggest you upgrade your os of hardy.although gutsy is good.after reloading update manager >>install gstreamer-ugly,bad etc

Revision history for this message
Maya Cain (ecloudrider) said :

Thanks ajmal_82, that solved my question.