How does one compile a Windows driver in 64-bit mode?

Asked by Jim Brassell on 2008-06-27

I have successfully downloaded ndiswrapper 1.53 and installed same. When I boot the system, I see in syslog where the ndiswrapper loader fails to load the ndiswrapper module because it found the kernal was 64-bit and the ndiswrapper module was not. I am running Hardy Heron 8.04 on an HP Pavilion a1430n AMD64 Athlon X2 machine. All of the other hardware works fine. Is this an issue with NETGEAR not providing a 64-bit version of ndiswrapper or is there a directive I can code during make to cause ndiswrapper to be compiled in 64-bit mode?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Jim Brassell
Solved:
2008-07-06
Last query:
2008-07-06
Last reply:
2008-06-28
Bhavani Shankar (bhavi) said : #1

Hello

Unfortunately, because Netgear havn't released any 64bit drivers, you cannot install under 64bit Ubuntu.
Sorry, but the only option is to install 32bit Ubuntu.

Once you have installed 32bit Ubuntu, follow this tutorial

http://ubuntuforums.org/showthread.php?t=652910

Regards

Bhavani Shankar.

Jim Brassell (jimbrass) said : #2

Thanks, Bhavani. Think I will stay with 64-bit Hardy. Do you know of any USB wireless adapters that have 64-bit drivers?

peter b (b1pete) said : #3

it depends where you live whether available or not - I can recommend one that I'm using for years on amd64 OR 386 (either xp or ubuntu)

- it is called RetailPlus
                    IEEE 802.11b/g
                    Mini Wireless USB Adapter (all as read off the manual cover)

- it has a ZyDas 1211 chipset; it was purchase from Office Depot store in Canada for approx $30.

Note: it works out of the box on ubuntu804 i386 and with ndiswrapper package on ubuntu804 amd64. mind you, this adapter HAS LINUX DRIVERS on the CD provided also but I never tried them - it was much easier and faster to use ndiswrapper to get it going under linux than a driver compile with all the hidden surprises/dependencies missing etc.

on amd64 don't forget to blacklist the native zydas driver otherwise it'll not work.

best of luck,
peter b

Jim Brassell (jimbrass) said : #4

Determined that there are no available, reliable 64-bit USB wireless adapters. Backleveled to 32-bit Ubuntu version.

LewisG (lewisgrimshaw) said : #5

There are plenty of wireless adapters that have 64 bit drivers, The philips SNU-6500 http://www.ciao.co.uk/Philips_Wireless_USB_Adapter_SNU6500__6350721 for example.

LewisG (lewisgrimshaw) said : #6

Try using ndiswrapper to load inf on linux