Raton loco

Asked by kewapo on 2008-06-24

El año pasado instale ubuntu 7.04 y no tenía este problema. Al actualizar a ubuntu 8.04, cada vez que arranca el portatil, durante 2 minutos no puedo tocar el touchpad porque el raton se mueve loco por la pantalla, abriendo ventanas y cambiando los menus de posición. Luego no vuelvo a tener el problema. Sin embargo si meto la tarjeta SD de mi camara de fotos en la ranura del portatil, y mientras la lee, vuelve a moverse loco el raton de nuevo.

No conozco en profundidad el sistema de drivers (¿podría ser una incompatibilidad entre el driver de usb y el del touchpad?) y tampoco la configuracion del servidor de las X (¿problemas de configuración?)
He reinstalado ubuntu 8.04 con el Cd, pero sigue igual.

Quizás con un poco de información en detalle conseguiría resolver el problema.
Gracias por adelantado.

Question information

Language:
Spanish Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Jorge González
Solved:
2008-06-30
Last query:
2008-06-30
Last reply:
2008-06-29

Hola kewapo.

Me gustaría saber si tu touchpad ha sufrido algún daño, caída o material líquido haya caído en él, porque no creo que sea un problema de hardware ni de drivers. Lo otro, ¿haz probado tu ratón con el LiveCd? ¿Tienes los mismos problemas?.

Estamos en contacto y un abrazo.

kewapo (kewapo) said : #2

Ayer inicid la sesion con el live-cd del Ubuntu 7.04 y el raton me iba perfectamente. Inicie la sesion con el live-cd del ubuntu 8.04 y el raton se me volvia como loco.
El el "visor de eventos" aparecían líneas de error que decían algo así como: "Wheel mouse lost of synchronization" un monton de veces

He puesto en /boot/grub/menu.lst al final de las líneas que comienzan por kernel... acpi=force apm=off sin resultado
He configurado xorg.conf en el apartado del raton Protocol auto y Protocol ImPS/2 sin resultado

Tendré que leerme algun documento que explique en profundidad el arranque del ubuntu 8.04 y las modificaciones respecto a la version 7.4 para ver si descubro algo
Si podeis indicarme dónde encontrar esta información me lo curro yo

Gracias por ayudarme. Si quereis que os heche una mano con algun tema me lo indicais (<email address hidden>).

Jorge González (jag2kn) said : #3

Compare la configuración de /etc/X11/xorg.conf en ambos sistemas el live y
el instalado

--
Jorge Andrés González
jag2kn (at) gmail.com
jgonzalez (at) idesoluciones.com
jorge.gonzalez (at) libertsoft.com
http://joorge.com
Cel: 301 217 78 60
Linux Counter 345082
Bogotá - Colombia - Sur América

kewapo (kewapo) said : #4

Ya había comparado los dos xorg.conf (el de ubuntu 7.04 y el de ubuntu 8.04) sin éxito.

Sin embargo, vamos avanzando. He probado a añadir al fichero /boot/grub/menu.lst, en el kernel que me arranca, la opción acpi=off. Resultado: ¡EL RATON YA NO SALTA!. Sin embargo al arrancar me da un error, con lo cual tengo que poner "acpi=off pnpbios=off". Con esto no me da errores al arrancar y el raton no me salta. El problema es que no puedo ver el estado de la batería.

Con ubuntu 7.04 si veia el estado de la bateria, y el raton no me saltaba. tiene que haber algun otro parametro o otra solucion mejor

Llevo toda la tarde pegado al portatil y ya no tengo ni ojos.
Gracias por vuestra ayuda. Ya me contareis.

Y lo dicho, si puedo hacer algo por favor, me lo decis

kewapo (kewapo) said : #5

He seguido investigando toda la mañana
Leer la documentación sobre el grub me llevo a buscar información del kernel 2.6.24. Por lo que cuentan en los foros, esta versión del kernel debe tener bastantes problemas con el acpi. No solo le pasa a ubuntu. He visto gente con Mandriva y otras distros que se ven forzadas a utilizar la opción acpi=ht e incluso acpi=off para que les funcione aceptablemente

 Lo que yo he hecho es poner en /boot/grub/menu.lst en la línea del kernel es poner la opción pci=noacpi. No se que repercusiones puede tener esto. No me muestra el estado de la batería, pero me funcionan los puertos usb y la tarjeta wifi.

Si tenéis más información, o una mejor solución, por favor, me lo decís.

gracias por todo.

Jorge Suárez de Lis (ys) said : #6

Buenas kewapo.

Yo te sugiero que pruebes a instalar el kernel 2.6.22 de la versión anterior de ubuntu. Añades los repositorios de la versión anterior, instalas...

linux-image-2.6.22-14-generic
linux-ubuntu-modules-2.6.22-14-generic
linux-restricted-modules-2.6.22-14-generic

Y prueba. No sé si será buena idea poner un kernel de una versión anterior. A lo mejor te da problemas con los drivers de la tarjeta gráfica (mayormente con los de nvidia o ati) y a lo mejor te ves obligado a instalarlos a mano, pero debería funcionar.

En el grub seleccionas el kernel viejo y ya está.

Best Jorge González (jag2kn) said : #7

Estando en Campus Party, tuve el este mismo problema (mas exactamente
anoche), revise si tiene estas cuatro lineas dentro Section "InputDevice"
del mouse

    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"

yo los que y se arreglo

cualquier cosa informemos, principalmente supongo que es por la linea del
protocolo

--
Jorge Andrés González
jag2kn (at) gmail.com
jgonzalez (at) idesoluciones.com
jorge.gonzalez (at) libertsoft.com
http://joorge.com
Cel: 301 217 78 60
Linux Counter 345082
Bogotá - Colombia - Sur América

kewapo (kewapo) said : #8

Thanks Jorge González, that solved my question.

Emiliano Raso (raso-emiliano) said : #9

Kewapo. Yo tengo una Acer Aspire 5710, con Ubuntu 8.10
Tengo el mismo problema desde la version 7.10

Lei todo el thread, pero al final no entendi como solucionarlo xD

Donde Jorge Gonzalez dice "revise si tiene estas cuatro lineas dentro Section "InputDevice"" a donde se refiere?

Estoy cansado de buscar la solucion y muchos conocimientos no tengo, asi que agradeceria que me ayuden.

Jorge González (jag2kn) said : #10

mire en el archivo xorg.conf, lo puede abrir para editarlo con esta linea en una terminal:

sudo gedit /etc/X11/xorg.conf

debe quedar algo como esto en la seccion de inpudDevice del mouse:

Section "InputDevice"
 Identifier "Mouse0"
 Driver "mouse"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ImPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Emiliano Raso (raso-emiliano) said : #11

Gracias jorge.
Mi xorg tiene solo estas secciones. La de InputDevice es la misma que Device o es otra y la tengo que agregar?

Section "Device"
 Identifier "Configured Video Device"
EndSection

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
EndSection

Emiliano Raso (raso-emiliano) said : #12

Lo agregue como una nueva sentencia y funciona EXCELENTE!

Muchisimas gracias! ese problema me tenia muy cansado porque no podia usar la notebook sin el mouse usb...

Emiliano Raso (raso-emiliano) said : #13

Lo agregue como una nueva sentencia y funciona EXCELENTE!

Muchisimas gracias! ese problema me tenia muy cansado porque no podia usar la notebook sin el mouse usb...

Fabián Rodríguez (magicfab) said : #14

Emiliano, nos puede compartir la versión final de su archivo ?

Yo tenía entendido que en 8.10 xorg.conf era ignorado para los "input device" como mouse y teclado.

Gracias.

Emiliano Raso (raso-emiliano) said : #15

Si si. Asi me quedó. Simplemente al final agregue lo que ustedes dijeron y ahora funciona mas que bien.

Section "Device"
 Identifier "Configured Video Device"
EndSection

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
EndSection

Section "InputDevice"
 Identifier "Mouse0"
 Driver "mouse"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ImPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Emiliano Raso (raso-emiliano) said : #16

No se ilusionen. No funcionó. Me habia parecido.

Recien la apague, limpié la notebook (por afuera) y ahora estoy usando el touchpad y sigue andando mal.