I cannot log in as a user, only root (except under terminal).

Asked by Doug Whitfield

Ok, this has been an issue for a few days now and is very irritating. I have run fsck as was suggested...didn't help. I have posted on ubuntu forums: http://ubuntuforums.org/showthread.php?t=834949 with not much response. I have posted on Yahoo! Answers. I have posted on a FOSS org (non-LUG) and a LUG listserv. After reading another post here, I set the home folder to 644 rather than the 777 I previously set it to trying to solve this problem. I did set my ubuntu up such that I can log in as root from the login screen. I can log in to any user account from terminal and I can create new user accounts. What I cannot do is log in from the typical log in screen as any user other than root. If I try to do that, I get this error:

'GDM could not write to your authorization file. Thus could mean that you are out of disk space or that your home directory could not be opened for writing. In any case, it is not possible to log in. Please contact your system administrator.'

There's plenty more info on the ubuntuforums.org post, but I think the GDM error is the real error, so I don't want to get too sidetracked with things I've tried and failed with. Thanks so much for your help!

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Doug Whitfield
Last query:
Last reply:
Revision history for this message
john (no2498) said :

im new but it looks like you need to get on as the other root i think its (su)

Revision history for this message
Doug Whitfield (douglasawh) said :

Actually, the fix for the issue can be found at http://ubuntuforums.org/showthread.php?p=5255701

Long story short: "To fix it, I logged in as root, started X, went to my home directory and checked the permissions. They were all off. Somehow, doing it from the gui fixed it but when I did chmod and chown nothing happened."