change desktop resolution

Asked by JPFGuambe on 2008-06-20

I Installed ATI driver on Ubuntu Hardy in order to run the all wonder Compiz-Fusion and AWN.
Before the installation of the driver i was running with 1280x1024.
After the installation of the driver compiz-fusion was running wow, but my maximum resolution was 1024x768.

How can i have 1280x1024 resolution?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2008-06-22
Last query:
2008-06-22
Last reply:
2008-06-21
Sam_ (and-sam) said : #1

Hi,
how about menu->system->preferences->monitor resolution settings?
There you should be able to choose the desired one.
However you can take a look in /var/log/Xorg.0.log which modelines are provided.
Or GUI ->system management.

JPFGuambe (ghlegs) said : #2

thanks sam, i took a look at /var/log/Xorg.0.log and i noted that the driver detected my monitor as an old monitor that only support at most 1024x768, is it because the monitor driver it's not installed?

Sam_ (and-sam) said : #3

Hi,
you could add the right modeline to the /etc/X11/xorg.conf or try
#sudo dpkg-reconfigure xserver-xorg
this will lead you thru your settings.

Edit with caution and before editing any systemfile backup is a must.
In the entry of xorg.conf are more details.

A Howto is here under >Things to try<
https://help.ubuntu.com/community/DebuggingXAutoconfiguration

Here is an automated modeline generator
http://xtiming.sourceforge.net/cgi-bin/xtiming.pl

After changes restart X with ctrl+alt+back

Try to put your monitor inf file from Win driver using the displayconfig-gtk tool

http://tombuntu.com/index.php/2007/10/26/displayconfig-gtk-saves-the-day/

please first install it open a terminal and type:

sudo apt-get install displayconfig-gtk
sudo diplayconfig-gtk

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

JPFGuambe (ghlegs) said : #5

thanks a lot marcobra, all i needed was diplayconfig-gtk command,
because in ubuntu there's no System->Administration->Screens and Graphics option in menu.

i selected my monitor model and rebooted, after that, it was working fine.
now i can real feel my compiz-fusion stuff.

JPFGuambe (ghlegs) said : #6

Thanks marcobra, that solved my question.

marcobra suggests this article as an answer to your question:
FAQ #128: “How to get better screen resolution”.

I installed UBUNTU 11.04 ( yes Help About tells me taht I use that version ) installed on a HP laptop having an ATI Mobility Radeon HD 3400 series display controller.
For Ubuntu the monitor is "Unknown", and it does not give the possibility to higher resolution than 800x600 (4:3) though the same dislplay runs in resolution 1440x900 running Windows 7.
How can I get a higher resolution ?