Another dull RealMedia question (sorry)

Asked by Gavin Hamill on 2007-02-12

(Feisty herd-3 - live environment)

I've read through many support tickets about RealMedia and was hoping for a reasonably clean way to get things moving.

I've followed the RestrictedFormats wikipage, and specifically

https://help.ubuntu.com/community/RestrictedFormats/WindowsCodecs

so I now have /usr/lib/codecs and /usr/lib/win32 populated with 30MB of DLLs and .so's

I also have every gstreamer-plugin package installed:

ii gstreamer0.10-pitfdll 0.9.1.1+cvs20060515-1
ii gstreamer0.10-ffmpeg 0.10.2-0ubuntu4
ii gstreamer0.10-plugins-bad 0.10.4-1ubuntu1
ii gstreamer0.10-plugins-bad-multiverse 0.10.4-3
ii gstreamer0.10-plugins-base 0.10.11cvs20070110-0ubuntu5
ii gstreamer0.10-plugins-base-apps 0.10.11cvs20070110-0ubuntu5
ii gstreamer0.10-plugins-good 0.10.5-1ubuntu2
ii gstreamer0.10-plugins-ugly 0.10.5-0ubuntu2
ii gstreamer0.10-plugins-ugly-multiverse 0.10.5-2

In addition, I have killed and recreated my gstreamer cache:

# rm -rf ~/.gstreamer-0.10
# gst-inspect-0.10

However, totem /still/ refuses to play RealMedia content..

ubuntu@ubuntu:~$ totem --debug rtsp://rmgeo.bbc.net.uk/news/media_acl/mps/fix/news/video/78000/bb/78213_16x9_bb.rm

(totem:11728): Gtk-WARNING **: Attempting to add `rtsp://rmgeo.bbc.net.uk/news/media_acl/mps/fix/news/video/78000/bb/78213_16x9_bb.rm' to the list of recently used resources, but not MIME type was defined
** Message: Couldn't initialize lirc.

0:00:01.875131000 11728 0x80930a0 ERROR totem bacon-video-widget-gst-0.10.c:337:bvw_error_msg_print_dbg: error message = Could not read from resource.
0:00:01.875226000 11728 0x80930a0 ERROR totem bacon-video-widget-gst-0.10.c:339:bvw_error_msg_print_dbg: error domain = 2005 (gst-resource-error-quark)
0:00:01.875253000 11728 0x80930a0 ERROR totem bacon-video-widget-gst-0.10.c:340:bvw_error_msg_print_dbg: error code = 9
0:00:01.875272000 11728 0x80930a0 ERROR totem bacon-video-widget-gst-0.10.c:341:bvw_error_msg_print_dbg: error debug = gstrtspsrc.c(1461): gst_rtspsrc_send (): /play/source:
Got error response: 461 (Unsupported Transport).
0:00:01.875295000 11728 0x80930a0 ERROR totem bacon-video-widget-gst-0.10.c:342:bvw_error_msg_print_dbg: error source = <source>
** Message: Error: Could not read from resource.
gstrtspsrc.c(1461): gst_rtspsrc_send (): /play/source:
Got error response: 461 (Unsupported Transport).

'Unsupported Transport' would seem that it doesn't know about rtsp - how can I verify and remedy this?

I would very much prefer to not install mplayer / totem-xine / RealPlayer GOLD etc. !

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Gavin Hamill
Solved:
2007-02-13
Last query:
2007-02-13
Last reply:
2007-02-13
Leandro Gómez (leogg) said : #1

Have you tried to uninstall the codecs and reinstall them with Automatix or EasyUbuntu?

http://www.getautomatix.com/
http://easyubuntu.freecontrib.org/

Gavin Hamill (gdh) said : #2

Nope - I'm keen to keep things as native to Ubuntu as possible - dependency on external 'magic scripts' is surely not the way forward for an integrated 'out of the box' OS :)

TBH, I'm not actually that interested in watching streaming media - this is more of a test to see how far on Ubuntu has progressed in what most users consider 'basic' (java/flash/divx/realmedia/quicktime/windows media)!

Automatix is generally not recommend.

The standard answer when someone wants to view Real content is to install Real player.

https://help.ubuntu.com/community/RealplayerInstallationMethods

The other option is to install totem-xine (totem with the xine backend rather than the gstreamer one).

Best Gavin Hamill (gdh) said : #5

Hi Alan. Thanks for the pointer. I noticed the existence of

http://archive.canonical.com/ubuntu/dists/feisty-commercial/main/binary-i386/

but the Packages file is empty - is this likely to be populated in the same way as dapper-commercial and edgy-commercial in time for feisty's release?

williamts99 (williamts99) said : #6

Glad you are trying it out, and yes it should be populated when they are ready :-)

I think rtsp should be handled by gstreamer good plugins (according to http://gstreamer.freedesktop.org/documentation/plugins.html).
It's working in Edgy, so why doesn't it work in Feisty?

I'm sorry, I didn't realize I was using totem-xine in Edgy. So, it's not working in Edgy, but a least we get a "RSTP streams cannot be played yet" message (using totem gstreamer).