Can't see Ubuntu at boot

Asked by Robbie Robinson on 2007-02-12

I installed Ubuntu on a SCSI drive by itself. I have another SCSI drive which has XP on it. Both SCSI drives are mounted on the same Adaptec input on the motherboard. I have an IDE hard drive mounted on a Promise card on a PCI slot on the motherboard which has another XP install on it. I have a CD player mounted on the on-board IDE secondary slot, but no drive mounted on the primary slot.

I had an Ubuntu CD I burned from a download and when I booted the CD it started up fine and I installed Ubuntu from the CD. When I rebooted after install and removed the CD it went straight to the 2 XP choices boot menu and never shows anything about Ubuntu. Inside XP I can see the Ubuntu partitions and drive, so it must have installed. I just can't see it at startup and it doesn't boot on its own. Can anyone tell me how to get it to boot at startup? I know I have a funky hard drive configuration but I've got both XP (1 on SCSI and 1 on IDE) booting just fine.
Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Robbie Robinson
Solved:
2007-02-13
Last query:
2007-02-13
Last reply:
2007-02-13
Bryce Harrington (bryce) said : #1

Hi Robbie,

This sounds fairly simple. Boot sequence is usually controlled by your BIOS.

First, when rebooting your system, go into BIOS (usually by holding down a key like DEL or one of the function keys). There should be a Boot menu (or Boot Sequence or some such).

Next check and see what the sequence is. You probably want to order it like, 1. CDROM, 2. SCSI, 3. IDE.

Depending on your BIOS, you may be able to specify which SCSI hd to boot from; if so, make sure to set it to the Ubuntu one. Or maybe there is a second menu for controlling the SCSI drives boot order, and you can set it there. If not, then you may need to move the drive with Ubuntu to be the first drive on the chain.

The reason you want the Ubuntu drive as the boot device is because it has the bootloader that will be able to let you choose to boot to either Ubuntu or one or the other Windows. (I don't think you'll be able to use Windows' bootloader to boot anything other than Windows.)

If after this you still have trouble, one thing that could help would be to see the contents of /boot/grub/grub.conf. But I bet adjusting things in BIOS will solve it for you. Good luck!

Robbie Robinson (robocopone) said : #2

Hi Bryce,

Thanks for the info. I went into the bios and found both a boot sequence option as well as what is called a hard-disk drive sequence.

I know Ubuntu is on the SCSI ID 01 so I placed that first in the sequence.

In the boot sequence I had limited options 1) diskette; 2) hard-disk drive C; 3) CD-ROM device. I could enable or disable them. All were enabled. I don't know what the bios considers the C: drive but I disabled the diskette and CD-ROM feature to see what would happen. I also moved the C: drive option to the top of the sequence.

When I rebooted I got an error after the Promise card booted saying "strike F1 to retry boot, F2 for setup utility". Several F1 taps and it continued to give the same message so I went back into the bios.

In the hard disk sequence option available things are: The 2 SCSI drives, the partitioned IDE drive (showing 2 drives because of the Promise card) and an option that says "System BIOS boot devices"

First I tried putting the IDE drive(s) first and when it booted I got this message:
GRUB loading stage 1.5
GRUB loading, please wait...
Error 17 (then it hung up)

Then just to be novel I put the "System BIOS boot devices 1st and the IDE drive(s) second. I got the same error message after the IDE drives booted.

Then I went back to the System BIOS boot devices first and all the other drives showing up in the same sequence they load in the BIOS

It went straight to the Win boot selection and loaded one of the XPs.

For further data, I tried to install Ubuntu on one of the IDE partitions earlier and it failed so I deleted the partition Ubuntu created and instead installed it on one of the SCSI drives. But when I put the IDE drives in front of the SCSI at least I got to GRUB. Could something have been left after the earlier install? It doesn't explain why the SCSI drives won't boot Ubuntu.

I'm probably making this more complicated than I should, but any advice would be much appreciated.

Bryce Harrington (bryce) said : #3

Wow, okay yes this is a pretty complicated setup. I'm not super familiar with running XP and Linux together, but I think this should be doable.

First off, lets try and remove some of the variables to simplify the situation. Disconnect the IDE drive and the SCSI drive with WIndows, and attempt to get that to boot. With only a single disk present, test to make sure that this drive at least boots up properly by itself. If it boots, then the problem is a drive configuration issue; if it doesn't, then it's a problem with the bootloader on the Ubuntu scsi drive. Like maybe the boot partition wasn't marked bootable or something.

To answer your question, yeah, it sounds like there is a grub bootsector left over from that previous install. However, other than being a point of confusion, it shouldn't harm anything.

Best Robbie Robinson (robocopone) said : #4

Ok, so it worked out pretty much with your help. Rather than disconnecting drives I simply killed the install on the SCSI drives and installed it back on the IDE drives.

I set the sequence to have the IDE drives boot first and lo and behold, up came Ubuntu. The secret was the sequencing as you said and I still have the Win boot secondary on the Ubuntu boot screen. I haven't tried that yet because I'm playing with Ubuntu, but if worse comes to worst I can always re-sequence the drives to get to XP.

I really appreciate your help in steering me to the solution. Now I can explore the world of linux which seems to me more and more to be an alternative to Windows.

Thanks again,
Best,
Robbie

Bryce Harrington (bryce) said : #5

Great to hear!

Good luck, and have fun. :-)

Bryce