Error activating XKB configuration

Asked by Sk1nk

Right after i logged in this Error poped up.

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

so as asked:
max@max-rechner:~$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "de", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "de", "", ""

max@max-rechner:~$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [de mac]
 model = macintosh
 options = [grp grp:alts_toggle]
 overrideSettings = true

I'm using the Apple Keyboard "MB110D/A"

I'm not pretty sure if it was my fault by configuring the .Xmodmap for the Applekeyboard (there is a mistake which changes the keymap 94 ("^") with the 49 ("<")) wich bugged me and i tried to handle and i reconfigured the Num-Pad because the Num-Lock Key isn't working correctly (after hitting it al the Numkeys are around the "K" key ... none of the other keys has any function left until you hit the "F6" Key twice.
Even now I wasn't able to get the F7-F12 Key back to their normal function, they got some specialfunctions like RaiseSound and aren't sending any keycode.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Bhavani Shankar (bhavi) said :


going into gconf (gconf editor command in a terminal)

desktop > gnome > peripherals > keyboard > general > host_computer > kbd

Then edit "layouts" and "options"(right click -> edit key and delete everything and then OK)

Then you can set up a new keyboard in System > preferences > keyboard.

and if it doesnt work, its a apparently a known bug in ubuntu under progress

Please feel free to add your comments there


Bhavani Shankar.

Revision history for this message
Sk1nk (ha-lecter) said :

hi, and thanks for response

it isn't related to the problem with the polish keyboardlayout, the layout works fine, all german specialkeys i need are were they have to be, but gconf-editor made it worse.

"^" and "<" are working correctly but the Num_Lock bug still exists, hitting this button makes the "J" the Numpad "1" ... the Num_Lock key the "F6" button ... you have to hit it twice to get back the normal keyboard ... while this "Num_Lock" is activated none of the other keys is working.

Although the F7-F12 Buttons have just their special function ... (Mute Sound, Raise Volume etc.)

BUT ... the Errorpopup is solved ;)

Revision history for this message
Bhavani Shankar (bhavi) said :

Do you mean umlauts with german keyboard?

Revision history for this message
Sk1nk (ha-lecter) said :

"Umlaute" are working, yes ... my problem are the F-Keys which i can't use.

Revision history for this message
vhjgjhjoljlk (hjkjhkhjlhjk) said :

I still haven't got surround sound working though I now have the channels in the mixer. I have tried out various solutions available but without success. however, I read some related info here you can also see it.

Can you help with this problem?

Provide an answer of your own, or ask Sk1nk for more information if necessary.

To post a message you must log in.