virtual terminals (CTRL+ALT+F#) won't work

Asked by R.M. Hildigerr V. on 2008-06-05

I just bought a Toshiba Satellite A215-S5837 and installed Hardy, and I'm having many problems.
One of them is that I cannot use the virtual terminals (CTRL+ALT+F#).
When I try all I get is a blank white screen, sometimes with vertical lines of colored dots.
Someone else had a similar problem a couple of years ago (Question #2299) and what they did is
edit etc/boot/menu.lst to pass "vga=791" to the kernel.
But I can't find etc/boot/menu.lst
I tried searching for menu.lst and I found /usr/share/doc/grub/examples/menu.lst
and /usr/share/doc/memtest86+/examples/grub-menu.lst
but neither of these seem to be what I'm looking for.
I need to know if passing vga=791 parameter to the bootloader is what I need to do, and
I'd also like to know exactly what the vga parameter is. If it's not what I need to do then what?
Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
R.M. Hildigerr V.
Solved:
2008-06-11
Last query:
2008-06-11
Last reply:
2008-06-05
Old_Soldier (charles.davis) said : #1

the correct path is /boot/grub/menu.lst

R.M. Hildigerr V. (moonsdad) said : #2

Thanks!
Now I've found the file but I don't know how to change it. I looked through it and I think that I need to edit line 89:

86 ## additional options to use witht he default boot option, but not with the
87 ## alternatives
88 ## e.g. defoptions=vga=791 resume=/dev/hda5
89 # defoptions=quiet splash

But I'm not sure what to change it to, should I copy the example on line 88 or just add vga=791 to the end of the
existing line or to the beginning of it, or what?

R.M. Hildigerr V. (moonsdad) said : #3

After looking at question #2299 again I think the line that needs changing may be #132:

130 title ubuntu 8.04, kernel 2.6.24-16-generic
131 root (hd0,4)
132 kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=46f613df-b029-4302-9041-d9ff720a35ac ro quiet splash
133 initrd /boot/initrd.img-2.6.24-16-generic
134 quiet

?

Please modify the

89 # defoptions=quiet splash

to

89 # defoptions=quiet splash vga=791

Save exit and then type:
sudo update-grub

Then to reboot the system type:

sudo reboot

Hope this helps

R.M. Hildigerr V. (moonsdad) said : #5

It didn't work.
I still cant get to the tty terminals.

R.M. Hildigerr V. (moonsdad) said : #6

at https://launchpad.net/ubuntu/+source/usplash/+bug/63558 a few people reported that removing splash from the kernel options solved their problems, so I tried that and it still didn't work. I don't know what else to try. Any suggestions?

R.M. Hildigerr V. (moonsdad) said : #7

Well I tried pressing e at the grub menu at startup to edit the kernel options trying every vga parameter from this list:

Colours 640x400 640x480 800x600 1024x768 1152x864 1280x1024 1600x1200
--------+--------------------------------------------------------------
 4 bits | ? ? 770 ? ? ? ?
 8 bits | 768 769 771 773 353 775 796
15 bits | ? 784 787 790 354 793 797
16 bits | ? 758 788 791 355 794 798
24 bits | ? 786 789 792 ? 795 799
32 bits | ? ? ? ? 356 ?

but nothing worked. I tried installing 7.10 and I could get to the VTs during the live session but after installation no go.
I reinstalled 8.04 first booting the live session to see if I could get to the terminals but I couldn't either before or after.
I also tried passing vga=791 to 7.10 but I'm too exhausted and frustrated to try all of them again with each distro.

R.M. Hildigerr V. (moonsdad) said : #8

Well, I fixed my other problem which was getting the wifi card to work under ubuntu,
but I'm still waiting for some help with this. ....
My graphics card is an ATI Radeon x1200 if that info will help you help me.
Thanks.

R.M. Hildigerr V. (moonsdad) said : #9

I finally got them working! Heres what I did in case someone else has this problem:
I used synaptic to install envyng-core
then System->Administration->Hardware Drivers
clicked on the enabled checkbox under ATI accelerated graphics driver
which then installed some stuff and asked for reboot
after which all my problems are solved!

Thanks to everyone who tried to help me.