No wireless connection on ibm thinkpad aironet

Asked by williamh on 2008-06-04

I can see SSID's but can't log on to any routers - either with WPA or WEP keys. seems to log on OK with unprotected networks. I've updated the firmware on the wireless card and can log in to wpa networks fine using windows XP but not with Ubuntu. I'm using the 'windows wireless drivers' to run the card and have modified the /etc/modprobe.d file to get this far but am now stuck... any help??? before i'm forced to return to XP land!!!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
williamh
Solved:
2008-06-29
Last query:
2008-06-29
Last reply:
2008-06-26
williamh (mail-williamhicklin) said : #1

any help please?? not sure where the problem is - tried everything - using a windows driver through ndiswrapper - is that compatible with wpa_supplicant???

would love to get it to work or is it not possible with this card??

williamh (mail-williamhicklin) said : #2

Any help?? I've followed pretty much every thread on this with no joy.

Reinhard Tartler (siretart) said : #3

windows drivers used by ndiswrapper is known to make trouble with wpasupplicant in some cases. in my experience it really depends on the actual windows driver that is used.

If you can rather try to use a native windows driver. Which is the best for you is hard to tell since you didn't state what wifi hardware you have. ibm aironet is way too vague, I personally have an ipw3945 based chipset, by previous thinkpad was equipped with an atheros chipset. Both were labeled ibm aironet.

williamh (mail-williamhicklin) said : #4

Thanks for your info - sorry to start with a basic question but how do I find out which chipset? I've looked in HAL device manger but can't see anything relevant. It calls the card a Cisco Aironet Wireless 802.11b the driver i'm using with Ndiswrapper is the one that worked in XP which was labeled neta504.

worryingly in the device manager, device tab it has vendor, device, device type and capabilities as unknown and status as none

does this get me any closer???

thanks

w

Reinhard Tartler (siretart) said : #5

see https://wiki.ubuntu.com/DebuggingHardwareDetection and more general https://wiki.ubuntu.com/DebuggingProcedures for details.

To learn about your hardware, please run 'lspci -vvv' and 'lspci' and show the output of them

williamh (mail-williamhicklin) said : #6

apologies to all... for some reason as though it is WPA. but it is WEP. To make it work I have to input the correct configuation using the manual config page in the networking GUI. No it works fine! No idea if it will work with the WPA network at work though....

thanks again for all your help and sorry it was a false alarm