libfontconfig1 broken dependency

Asked by Michael Lee on 2007-02-05

Attempting to sync my Pocket PC to Evolution in 6.10 with Multisync and the synce plugin. While trying to install the necessary packages somehow I have broken the libfontconfig dependency. After attempting to fix using the "sudo apt-get install -f" fix I still get an unable to fix message in the console which reads:

libfontconfig1: Depends: fontconfig-config (=2.3.2_7unbuntu2) but 2.4.2_1 is installed

E: error, pkgProblemResolver::Resolver generated breaks, this may be caused by held packages.

E: Unable to correct dependencies.

I have found the broken package with Synaptic, but don't know what to do about it. Can you help?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Lee
Solved:
2007-02-10
Last query:
2007-02-10
Last reply:
2007-02-10

What happens if you open a terminal and try:-

sudo apt-get update
sudo apt-get install fontconfig-config

Also can you attach (not paste) your sources.list?

Michael Lee (re4merz) said : #2

Did update, packages fetched ok. However on the fontconfig- install the same unmet dependency message appears as earlier

libfontconfig1: Depends: fontconfig-config (=2.3.2_7ubuntu2) but 2.4.2-1 is to be installed

E: Unmet dependencies.

Suggestion followed... "Try 'apt-get -f install' with no packages (or specify a solution).

Attempted the above suggestion but failed as before.

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

How do I attach the sources.list? Should I send you an e-mail or can it be done here?

MDL

Sorry, I forgot you can't attach to support tickets.

Paste it in will be fine.

Michael Lee (re4merz) said : #4

The sources.list output

deb http://us.archive.ubuntu.com/ubuntu/ edgy main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ edgy main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ edgy-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ edgy-updates main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
# deb http://us.archive.ubuntu.com/ubuntu/ edgy universe
# deb-src http://us.archive.ubuntu.com/ubuntu/ edgy universe

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://us.archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu edgy-security main restricted
deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted
# deb http://security.ubuntu.com/ubuntu edgy-security universe
# deb-src http://security.ubuntu.com/ubuntu edgy-security universe

MDL

Hmm, I wonder if there is some broken dependancy that requires another repository. I suggest you enable the universe and multiverse repositories, then update then try an upgrade again to see if this rectifies it.

This page details how to do that:-

https://help.ubuntu.com/community/Repositories/Ubuntu#head-5bbef89639d9a7d93fe38f6356dc17847d373096

Michael Lee (re4merz) said : #6

I went to "Software Sources" under System>Administration.

All of the boxes for (default) Ubuntu 6.10 were already checked

* (universe)
* (main)
* (multiverse)
* (restricted)

Went ahead and ran update from the terminal.

Received this error message

E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)

E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Michael Lee (re4merz) said : #7

Is there a way to remove fontconfig-config 2.4 and revert back to fontconfig-config 2.3 or use a newer version of libfontconfig that will accept fontconfig-config 2.4?

Michael Lee (re4merz) said : #8

Is there a way to edit the dependency info in libfontconfig to allow it to reference fontconfig-config-2.4? Currently the fontconfig-config dependency is set as (=2.3.2-7ubuntu2) but 2.4 is installed.

Michael Lee (re4merz) said : #9

In order to correct the problem at this point, do I need to reinstall Ubuntu?

Kees Cook (kees) said : #10

I suspect the "backports" in your sources may be causing problems. To force a specific version of libfontconfig1, try this:

  sudo apt-get install libfontconfig1=2.3.2-7ubuntu2

Michael Lee (re4merz) said : #11

Tried the specific input with the same results. See below.

root@re4merz-desktop:~# sudo apt-get install libfontconfig1=2.3.2-7ubuntu2
Reading package lists... Done
Building dependency tree
Reading state information... Done
libfontconfig1 is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  libfontconfig1: Depends: fontconfig-config (= 2.3.2-7ubuntu2) but 2.4.2-1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Best Michael Lee (re4merz) said : #12

Kees,

Thanks. I tried your suggestion with fontconfig-config. This worked.

sKru4 (kaloyan-rs) said : #13

Can u tell mu how that happened? x)
(i'm quite new 2 linux x\ )

sKru4 (kaloyan-rs) said : #14

nvm, made it x)

I had a similar problem trying to install latest version of QPxTool from Debian unstable. It had dependencies on libqt3-mt then libfontconfig1 then fontconfig-config
It got stuck when installing fontconfig-config. This blog helped me. http://bluebones.net/2007/01/ubuntu-dapper-is-not-debian-unstable/

Did the below command to solve it.
sudo apt-get install -f fontconfig-config/edgy

Michael Lee (re4merz) said : #16

Samir,
Thanks for the additional info. Sounds like I did something similar.

Michael Lee

Mr.Sphinx (mr-sphinx) said : #17

I have the same problem, except when i try to enter "sudo apt-get install libfontconfig1=2.3.2-7ubuntu2", Ubuntu tells me that gnomad2 requires it to run and i can't swap it.

Can anyone tell me how to uninstall gnomad2 without using the package manager or the terminal?