"Error activating XKB configuration" on every boot

Asked by laptoplinux

Since upgrading to Hardy I receive this message on every boot:

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
10400090

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

The requested output is as follows:
:~$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "jp106", "jp,jp", "latin,", "grp:alt_shift_toggle,grp_led:scroll"
_XKB_RULES_NAMES(STRING) = "xorg", "jp106", "jp,jp", "latin,", "grp:alt_shift_toggle,grp_led:scroll"

:~$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

 layouts = [jp latin]
 model =
 overrideSettings = true
 options = []

:~$ lsb_release -rd
Description: Ubuntu 8.04
Release: 8.04

:~$ apt-cache policy packagename
W: Unable to locate package packagename

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Dennis Dirdjaja
Solved:
Last query:
Last reply:
Revision history for this message
Dennis Dirdjaja (dcd-ditsch) said :
#1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at [WWW] https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see [WWW] https://help.ubuntu.com/community/ReportingBugs .

Revision history for this message
Dennis Dirdjaja (dcd-ditsch) said :
#2

Could you please synchronize your settings in GNOME (the graphical interface) with the settings in your xorg.conf (or clean out one of them)?

Revision history for this message
laptoplinux (laptoplinux) said :
#3

Thank you for the reply. I am sorry but can you explain how I can do that?

Revision history for this message
Dennis Dirdjaja (dcd-ditsch) said :
#4

Please open the gconf-editor by pressing Alt+F2 and typing gconf-editor into the box. Then navigate to the key /desktop/gnome/peripherals/keyboard/kbd and reset the layouts key by right-clicking on it and invoke the step in the context menu. This should clear out the setting and take those from your xorg.conf.

Hope this helps.

Revision history for this message
laptoplinux (laptoplinux) said :
#5

Thank you for the instructions. This did solve the problem with the error message. But I noticed that certain keys on my keyboard were no longer functioning properly...particularly the underscore key. So I went to the keyboard control panel to configure and test my keyboard...and of course the error message returns. I reset the layouts key again just because the error message is more annoying than the inconvenience of the keyboard problem. Do you have any idea why this is happening? This all started when I upgraded to Hardy.

Revision history for this message
Best Dennis Dirdjaja (dcd-ditsch) said :
#6

You can also try the other way round: Open your xorg.conf in an editor with root privileges, e.g. gksu gedit /etc/X11/xorg.conf

Then, search your keyboard layout section and comment the XkbVariant and XkbOptions, if existing. This can be done by typing a # as first letter in that lines.

Revision history for this message
Virtuo (pierre-ruyssen) said :
#7

Hi,
I actually add the same problem as reported above. Commenting out XkbVariant and XkbOptions in xorg.conf did actually solve the problem.
Thanks.

Revision history for this message
laptoplinux (laptoplinux) said :
#8

Thanks Dennis Dirdjaja, that solved my question.