synaptic package manager wont open

Asked by crazyfro on 2008-05-31

so basicly the title says it all, no error msg or anything. thats probably just the biggest issue i have, when i try to update my computer through the update package thing (sry, a bit slow on the linux lingo) it freezes and then my internet shuts down. i am at a point where i have to do upgrading through a terminal window. Also, when i do that and type in the first command "sudo apt-get update" i get this msg before it starts

*****@*****'s Laptop:~$ sudo apt-get update
sudo: unable to resolve host *****'s Laptop

so i duno if that has anything to do with it but yeah, just trying to give as much info as i can think of...,
oh and i also have changed the network hosts name too prior to the problem starting

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Leo Arias
Solved:
2008-06-01
Last query:
2008-06-01
Last reply:
2008-05-31
Leo Arias (elopio) said : #1

I found this problem some weeks ago. A quick workaround was:
Alt+f2, write gksudo and then execute xterm
That way you will have a root terminal.

To fix the problem, you should check
https://answers.launchpad.net/ubuntu/+faq/93

Best Leo Arias (elopio) said : #2

Leo Arias suggests this article as an answer to your question:
FAQ #93: “Cant' use sudo: unable to resolve host ....”.

crazyfro (albert-chu) said : #3

Thanks Leo Arias, that solved my question.