broadcom BCM4310 wifi on acer travelmate 5520

Asked by peter b on 2008-05-30

hello to all.

lspci ==> output

05:00.0 Network controller: Broadcom Corporation BCM4310 USB Controller (rev 01)

v strange ==> no id ?

sudo lshw -C network ==> output

  *-network UNCLAIMED
       description: Network controller
       product: BCM4310 USB Controller
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:05:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0

ndiswrapper of no help ==> installs driver but no message re hardware present

is it the hardware probing/detection that 'sees' it as a usb controller ?

does anyone one have any idea how can this be solved ? the preinstalled xp sees it ok and working.

I just had a zydas 1211 wifi dongle around ==> plugged it in and was immediately seen by hardy and connected right away. lsusb output with this setup below

$ lsusb
Bus 006 Device 004: ID 064e:a101 Suyin Corp.
Bus 006 Device 002: ID 0ace:1211 ZyDAS 802.11b/g USB2 WiFi
Bus 006 Device 001: ID 0000:0000
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 002 Device 002: ID 08ff:1600 AuthenTec, Inc.
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

any help/tips appreciated.

peter b

Bus 003 Device 001: ID 0000:0000

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
peter b
Solved:
2008-05-31
Last query:
2008-05-31
Last reply:
peter b (b1pete) said : #1

sorry for last line, it does not belong here - previous post.

peter b (b1pete) said : #2

solved ==> wrong driver - driver that works with win (supplied) DOES NOT work in linux/hardy

for anyone interested, dell provided driver (v big file ~90MB) works just fine with hardy -->pls follow

http://backports.ubuntuforums.com/showthread.php?s=78d2bb65d16dd1d65f8386959952ff7e&t=650729

which is the classic ndiswrapper driver install howto --> nothing special

and

http://support.dell.com/support/downloads/download.aspx?c=us&cs=12&l=en&s=bsdv&releaseid=R174291&SystemID=VOS_N_1500&servicetag=&os=WW1&osl=en&deviceid=9805&devlib=0&typecnt=0&vercnt=4&catid=5&impid=-1&formatcnt=1&libid=5&fileid=236819

for driver download.

peter b