Multiple Hard Drives

Asked by RattleHead on 2007-02-02

I have 2 HD but only one is showing up how can I use both? My primary is used but the slave is not. Im a extreme newb to linux so any help would be greatly appreciated!!
\_/

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
RattleHead
Solved:
2007-02-11
Last query:
2007-02-11
Last reply:
2007-02-10

Is this during the installation process, or after you have installed Ubuntu?

RattleHead (eaton72) said : #2

After I have installed... I reformated both hard drives during the install.

Bryce Harrington (bryce) said : #3

Can you post the contents of your /etc/fstab file, and the output from the `mount` command here?

Thanks,
Bryce

RattleHead (eaton72) said : #4

How do I get that for you?, remember Im a newb ;)

Bryce Harrington (bryce) said : #5

Oh, sorry:

Open up a Terminal window and type the following:

$ mount

$ cat /etc/fstab

Then copy and paste everything that was printed out, here.

Bryce

RattleHead (eaton72) said : #6

No problem here you go

/dev/hda2 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
/sys on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
devshm on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
lrm on /lib/modules/2.6.17-10-generic/volatile type tmpfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda2
UUID=8c34c060-a97c-40e6-baa1-0593a4a0be28 / ext3 defaults,errors=remount-ro 0 1
# /dev/hda5
UUID=3551abc8-cad4-4b8b-a6cb-a224200e69b2 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/ /media/floppy0 auto rw,user,noauto 0 0

Bryce Harrington (bryce) said : #7

Okay, in this output, there are references to hard drive A ("hda") but none to a second hard drive ("hdb").

Go to Administration -> Disks, and see if it shows both of your hard drives in the Storage list. Click on them to see if one is named "/dev/hdb". If so, then click on the Partitions tab. Check to make sure the partition(s) are marked 'Active', and if not, try changing it to active.

You will also want to check the 'Access Path' settings for the partitions.

RattleHead (eaton72) said : #8

file:///home/rattlehead/Desktop/Screenshot-Device%20Manager.png

I dont have the option for disc under administration but I checked the device menu and it looks the same as the primary drive as far as I can see

Bryce Harrington (bryce) said : #9

The screenshot isn't coming through.

Can you describe in more detail what you're seeing? Also, do you see a secondary drive in the device menu? What is its 'Access Path' setting?

RattleHead (eaton72) said : #10

82801EB/ER(ICH5/ICHR) IDE CONTROLER\IDE SLVE\MAXTOR\6L08PO

linux.sysfs_path_device strlist /sys/block/hdb

does this help???

Brian Murray (brian-murray) said : #11

Please add the output of your kernel messages via the command 'dmesg' in a terminal. These will help us determine whether or not your secondary hard drive was detected. Thanks in advance.

Best RattleHead (eaton72) said : #12

Never mind I actually found what I did wrong during the initial install but I have fixed it now!! thanks for the help
\_/