Buffer I/O Error

Asked by softwerx on 2007-02-02

I'm trying to run Ubuntu Dapper Drake from a live cd - gotten from shipit - and keep getting:

Buffer I/O error on device dm-0, logical block ####### <- numbers incrs.

I've tried using several different discs and all do the same thing. All the discs are from shipit. I've installed Ubuntu without any problems in VMWare. This problem only occurs when booting from a disc.

Sys Specs:
celeron 1.8 ghz
1 gig ram
60 gig WD hdd - windows 2003 server
40 gig WD hdd - as of yet, unformatted/unpartitioned drive
generic cd-rw/dvd rom
lite-on dvd-rw
Nvidia FX 5200 vid card

What could possibly be the problem? I'm sure that it isn't with any of the discs, and probably not with either of my disc drives.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
softwerx
Solved:
2007-02-03
Last query:
2007-02-03
Last reply:
2007-02-03
Bryce Harrington (bryce) said : #1

I found someone reported a similar issue here:

http://ubuntuforums.org/showthread.php?t=220703&page=1

It sounds like they got it fixed by doing the following:

1. Press F6 when the liveCD boot menu comes up to alter the boot options.
2. Add the following at the end (before the '--'):
pci=noacpi ide=nodma ide=reverse
3. Boot

I had to do the pci=noacpi bit myself when installing Ubuntu on AMD64.

See if that helps?

softwerx (smichaels1) said : #2

I've run across that same thread however, the solution does not work for me.
I have 4 Ubuntu 6.06 lts discs here, all from Shipit, and they all do the same thing when trying to boot the live CD.

I really need some help with this issue as I'm wanting to actually install Ubuntu to my spare hard drive so that I have a dual boot setup with Windows 2003 server.

williamts99 (williamts99) said : #3

You may want to download the latest release of Ubuntu, which is 6.10 and see if you have any better results.

Best softwerx (smichaels1) said : #4

Thanks to all of you who have given suggestions as to my problem.

I found the answer to be a problem with my vid card. I changed the bios to use onboard video and plugged the monitor back into the mobo and everything went as it should.

..now I just need to get Nvidia drivers for Ubuntu...

The following page details the Ubuntu way to install the NVidia binary drivers.

https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia