Stuck in Busybox after updates to 8.04

Asked by John Fino on 2008-05-26

I am running Hardy installed in Windows XP, installed on an external USB hdd.
Hardy has been working fine for several weeks now, until yesterday. After installing the automatic updates yesterday, and restarting, I got stuck in Busybox. Busy box happened to me once before - turns out I had a USB flash drive plugged in, and it screwed up the boot order. However, this time, this is not the case. It seems to be one of the updates.
I uninstalled Ubuntu from inside XP, downloaded a whole new ISO, checked it with winMd5sum, everything was kosher, it installed inside windows fine. It booted smoothly into Ubuntu. Once in Ubuntu, all I did was install the updates (all 102 of them), restart, and wham! I'm back stuck in Busybox.
All the Busybox issues I can find online are related to install. Installing is not my issue, I can install fine.
I suspect that one of those updates is screwing with how Ubuntu loads on my system, but I really don't want to have to re-install Ubuntu again, and install all 102 updates one by one to figure out which one (or three) is the culprit.

Help is appreciated, I really like Ubuntu (even though a USB and installed inside XP, it's 4 times faster than XP) and I'd like to stick with it. I'm a newbie, but I can follow directions if they're clear and thorough.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2008-06-08
Last reply:
2008-06-21

This question was reopened

Jim Hutchinson (jphutch) said : #1

John,

I don't have any experience with Wubi (I'm assuming that's how you installed) so I don't know if there are any issues with how hardware is recognized or drivers installed. It's a fairly new project so there may be some bugs in it still; although I hear they did a pretty good job with it. It is, however, an added variable.

Because most issues are in some way hardware related, please give us some details on the computer you are installing on including graphics, motherboard chipset (if you know) or make and model of the PC, type of RAM and how much, audio chipset and anything else you can think of. A shot in the dark guess is that maybe it's a PulseAudio issue. That is a new audio driver in Hardy about which I know nothing but I have heard of a fair number of issues with it. Googling for PulseAudio turns up a lot of info on various fixes. Here is the general wiki page https://wiki.ubuntu.com/PulseAudio. Maybe something there will help. Again, I'm just guessing but maybe disabling it will help or just rule it out as a cause.

John Fino (tauricity) said : #2

Thanks Jim,

I've seen PulseAudio around, related to Flash 9. You've given me a place to start, thanks.
I am going to do another fresh install - when I get in I'll disable Pulseaudio and watch closely what programs get updated each day. And see what happens...

Dell 4600c
Pentium 4 2.66GHz, 865PE Intel chipset
XFX GeForce 6200 low-profile graphics card, 256 DDR2
1 GB ram (2x 512)
Internal Hard drive is a serial ATA (where XP is)
External Western Digital 320 GB USB drive (where Ubuntu is installed)
(I looked around for the audio chipset, couldn't figure out where to find it. Google was no help, either.)

Jim Hutchinson (jphutch) said : #3

Yeah, there do seem to be issue with flash and possibly related to PulseAudio. Not sure how that might affect you but a place to start. Another thought I had is the external drive. I installed on a Seagate drive later to discover that it powers down when idle and it breaks ubuntu. I don't know if that might be an issue with the WD drive or not but booting off usb drives is probably somewhat "experimental" still so that may be an issue too - especially if an update makes changes to usb. Just another guess but maybe something to keep an eye on too.

gatmaitan20 (gatmaitan20) said : #4

I have the same problem, after installing the automatic updates I suspect that the one causing this is the new kernel version, .16 generic to .17 generic Linux kernel. So for now I'm not installing the kernel updates for the reasons that I don't want to encounter the same problem again. According to the update details these update should be installed somewhere other that installing it directly using the package installer.

John Fino (tauricity) said : #5

Alrighty - very nice gatmaitan20.
I was going to remove pulseaudio (Jim, you said to disable it, I figured you meant remove) but removing pulseaudio forces the removal of ubuntu-desktop, which made me nervous.
So, following gatmaitan20's hunch, I installed all the updates except any that said "kernel". Ubuntu restarted just fine.

Here's what I didn't install (some didn't say "kernel", but are tied to others):
linux-generic (2.6.24.17.19)
linux-headers-2.6.24-17.31
linux-headers-2.6.24-17-generic
linux-headers-generic (2.6.24.17.19)
linux-image-2.6.24-17-generic
linux-image-generic
linux-restricted-modules-2.6.24-17-generic
linux-restricted-modules-generic
linux-ubuntu-modules-2.6.24.17-generic

I'm going to go ahead and install these now, restart, and see if I get stuck in Busybox.

John Fino (tauricity) said : #6

It's not the ones with "headers" in the name.

John Fino (tauricity) said : #7

I installed the "headers,"restarted, but that wasn't it.

So, then I installed only "linux-image-2.6.24-17-generic", which required a restart.
That did it. Stuck right in busybox. That's not to say the other 5 kernel updates wouldn't do the same thing. But at least it's good to know where the bug starts.

John Fino (tauricity) said : #8

So, there's no way to install any other "kernel"s without installing "linux-image-2.6.24-17-generic". Gatmaitan20, have you reported this as a bug?

gatmaitan20 (gatmaitan20) said : #9

Hi John, nope I haven't reported it yet. For now I think there's no easy way to install the linux image 2.6.24.17 generic. I'm busy at my work in the office. Testing bugs.

Quotient (abinteract) said : #10

John.
I'm having the same problem, and I'm not sure what to ask.

You said you were going to do a "fresh install."

a) What do you mean by "fresh install"
b) Would a fresh install lose all my customized settings and files?

I'm new to ubuntu, and I want to back up the files (at least) and settings on the computer before
trying anything, but I'm not aware how to "login" to my account through a LiveCD session.

(I'm clueless about Busybox).

John Fino (tauricity) said : #11

Quotient:

I don't know anyway around busybox and back into Ubuntu. If you ever find out, do let me know. The only command I've ever successfully used with busy box is "reboot", so I can restart w/o killing the power. I am also new to Ubuntu.

Unfortunately, the only solution I came up with is to uninstall Ubuntu from XP Add/Remove Programs, then reinstall the whole thing. I don't know of any way to save your settings. This does wipe clean all those little niceties and settings that I had just how I like them. Very aggravating. (If you know how to back up Ubuntu settings, please let me know before the next set of updates comes down the pipe and kills my Ubuntu install again!)

You then install all the updates from the update manager EXCEPT:
linux-generic (2.6.24.17.19)
linux-image-2.6.24-17-generic
linux-image-generic
linux-restricted-modules-2.6.24-17-generic
linux-restricted-modules-generic
linux-ubuntu-modules-2.6.24.17-generic

What "kernel" updates have to do with Wubi or external hard drives (boot order, maybe?) I haven't the foggiest. I filed this as a bug today, if you have a chance, pop over to Bug #236307 and second it (tell them this happened to you, and how your situation may be or may not be different).

Sorry I don't have better news, this was pretty close to a Ubuntu-killer for me. I almost gave up but gatmaitan20's insight saved it. However if I have to keep uninstalling and installing Ubuntu... I'll wait until my next computer where I have two internal hdds and skip the Wubi install entirely.

Quotient (abinteract) said : #12

Thanks John...I salvaged my installation with your insight coupled with the first of Knut Karevoll's suggestions, and my own previous, but limited experience.

I can't say I figured out the cause-effect relationship, but it led me to the right path of a working computer.

My intention was to backup my home folder to a networked computer, thinking I would have to do a fresh install, but I ended up fixing the problem (however inelegantly).

My first clue, in retrospect, was that after the upgrade, but before the restart that started the busybox-syndrome, I did look at my menu.lst file, and it looked like a hybrid: it had duplicate sections, with one referencing 2.6.24-17 and the other referencing 2.6.24-16. I trusted that this was normal, or at least acceptable to the OS. Well, maybe it's not.

1) I loaded the LiveCD and started a live session (I'm not sure how you would do this in Wubi but I think you will have a parallel).
While I was initially able to see my home folder, I couldn't copy it, because I didn't have permisison to do more that look at. So, I asked for help.
References:
https://answers.launchpad.net/ubuntu/+question/34816

2) I followed Knut's first suggestion to run " 'sudo nautilus' in a terminal. This will open a new window witch have root rights."
Note: I'm not sure if this step was actually necessary, but I did in fact do it. I got a terminal window as expected, but I also got an error message. Regardless, I kept open the terminal window that appeared and used it for the following steps.

3) Because I have some experience editing my menu.lst file to get Ubuntu stable, I went into the folder that houses the file.

4) There I deleted the "hybrid" menu.lst file and restored my menu.backup file from the pre-2.6.24-17 upgrade.

5) I also saw "duplicate" files in the folder: one set for linux 2.6.24-17 and one set for 2.6.24-16. I deleted all the files with 2.6.24-17 in the file name.
I did this because of your successful troubleshooting.

6) Rebooted...all was well.

Now, *what* actually worked? I'm not sure. I'm not in a position to experiment, since I have to keep the computer up and running for my father.

So, the logical question is: "Which kernel am I actually running? -16? or -17?" At this point, I'm not aware how to determine that.

I think we're narrowing down the problem though.

John Fino (tauricity) said : #13

Wow. That makes sense, running a live session off the cd to get in, I like it.

So - now that you're back into normal-booting Ubuntu: do you have those same kernel updates waiting for you in the download manager?

Quotient (abinteract) said : #14

Excellent question. When I did the first successful reboot, I actually waited to see if the same kernel updates would appear again.

They did not!

That's why my question is: Can one have two kernels simultaneously available for use (-16 and -17), even though only one can load at boot time?

I have the impression that while I installed -17, I'm loading -16. I don't know how to check.

John Fino (tauricity) said : #15

Well, we seem to have gotten to somewhere here. Unfortunately this is also the point where I doubt I can be much help - I don't even know what kernels do.
I think, for now, until I see a -18 come up, or there's some relatively simple fix for this, I'm just going to stick at 16. Definitely post here if you learn anything new. (Maybe one day I'll have strep throat again and have the time to try your solution - if I hadn't been sick this week I wouldn't have had the time to futz with this at all, so, silver lining, I guess.)

Andrew Hart (andrew-crawwler) said : #16

Hi guys,

I too ran into this problem just a few minutes ago. I had no idea what busybox was and found this thread via google. I am running Wubi and I've found that I can get a running Ubuntu by quickly hitting `Escape` during the boot sequence (after selecting Ubuntu as the operating system but before the Ubuntu splash screen appears). This presents me with a list of kernel choices among which is the old -16 kernel. By selecting that one, I'm back to where I was before the update.

Unfortunately, I don't know enough yet to know how to fix it so the default is the -16 kernel. I'm going to try Quotient's suggestions, but I thought I'd post how I got back to a running Ubuntu without doing any fresh install / loss of settings.

-Andrew

Quotient (abinteract) said : #17

Hi, Andrew.
I tried that actually, when I was experiencing the busybox-syndrome, but it didn't work for me. No matter which Grub option I selected (e.g., recovery mode), I'd still went straight into busybox.

I'm glad it was more straightforward for you.

That being said, I don't think anything is wrong with the kernel (-17), just the installation/upgrade process.

If only we all had more time to play.

Aaron

Christoph Donges (cdonges) said : #18

I have the same issue.

John Fino (tauricity) said : #19

Uh oh. -18 just came down the pipes. Anyone willing to try this? I'm not really.

John Fino (tauricity) said : #20

Arrrrrrrgggghhh! Don't do it! I didn't install any of the 6 old offenders (see above) and it bonks again!

So, be warned, one of the other new updates brings back this bull***t bug. I guess the updaters for this kernel haven't seen this bug. Anyone want to try to contact them? Their names are on the updates.

In any case, I'm absolutely fed up with Wubi/ Ubuntu because of this. I can't do another half dozen installs to see which update breaks Wubi/ Ubuntu. If this bug actually gets fixed, would someone post the here? Maybe I'll try it again. Otherwise, back to slow, old XP.

Andrew Hart (andrew-crawwler) said : #21

I've noticed this too: the same symptoms occur with the -18 kernel. There is a surprising amount of information available pertaining to situations related to this bug, indicating that many people are experiencing similar behavior. though I must say I've tried most of what I read without success. Here's the scenario, and some links to resources:

Busybox gets invoked when the boot process can't continue for one reason or another. In my case, it was because it couldn't find the device on which the root filesystem (/) was stored. This generated the following error:

mount: Mounting /dev/disk/by-uuid/2E0E-0CE2 on /root failed: No such device
mount: Mounting /root on /host failed: Invalid argument
ALERT! /host/ubuntu/disks/root.disk does not exist. Dropping to a shell!

BusyBox v1.1.3 (Debian 1:1.1.3-5ubuntu12) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

This output looked very similar to a question I came across in ubuntu forums, so I'll post it here in case it solves the problem for anyone else (it didn't for me, but it taught me a lot):
http://ge.ubuntuforums.com/showthread.php?t=813090

Also, there is even a bit in the Troubleshooting portion of the Wubi site that provides 2 potential solutions to this problem... (again, neither worked for me, but apparently they fix everything for some users..):
https://wiki.ubuntu.com/WubiGuide#head-9fe000fa2e31a632fdcf384438b2aee35076c623

Quotient (abinteract) said : #22

Hi, folks. Sorry for the delay.

First off: I did manage to upgrade to -18 with some troubleshooting, and today I just updated to -19 flawlessly.

Using the command 'uname -a', I got:
Linux <privatecomputername> 2.6.24-19-generic #1 SMP Wed Jun 4 15:10:52 UTC 2008 x86_64 GNU/Linux

My overall system stability was predicated on two things: BIOS and menu.lst settings.

--------------

Here's a more comprehensive history:

Firstly, before my 'Busybox syndrome,' my computer wasn't stable (freezing---seemingly upon media events: sound/video/etc.).
I built the computer, set up the BIOS, booted from the LiveCD to try it out, with the intention of installing it. However, Ubuntu loaded from the CD but the system froze.
I rebooted and started over multiple times, but Ubuntu from the LiveCD would routinely freeze, however never at the same point.

I learned through the LiveCD what temporary settings I needed (or at least thought I needed) for stability:
xforcevesa acpi=off noapic nolapic

So, I installed Ubuntu to my computer (x86; a single-boot system; no Wubi on Windows). When I rebooted the computer for the first time off the hard-drive, the system froze, like when running off the LiveCD.
So, I looked for help, and learned about Grub. I booted through the Grub options and applied the temporary settings that worked before. Then I made those temporary changes permanent by updating the menu.lst file (command: sudo update-grub).

Now, the computer was stable, but I 'soon' realized that the computer hadn't been detecting any usb peripherals since the very beginning (no printer/no thumb-drive). So, I researched usb problems and learned about the 'irqpoll' setting.

I decided to use combinations to see what worked in the menu.lst file. Here are some results I documented:

>Stable: xforcevesa acpi=off noapic nolapic But no USBdrive or printer
>
>Tests with: irqpoll xforcevesa acpi=off noapic nolapic
>
>irqpoll What works: USBdrive (ID 058f:6331) and printer (hp:/usb/OfficeJet_V40?serial=MY28RG50TDWN) + (ID 03f0:0f11) But Unstable
>irqpoll xforcevesa What works: USBdrive (ID 058f:6331) and printer (hp:/usb/OfficeJet_V40?serial=MY28RG50TDWN) + (ID 03f0:0f11) But Unstable
>irqpoll acpi=off What works: USBdrive (ID 058f:6331) and printer (hp:/usb/OfficeJet_V40?serial=MY28RG50TDWN) + (ID 03f0:0f11) But Unstable
>irqpoll noapic What works: nothing but stable

Because IRQs can be set by the BIOS, I looked for clues there. What I soon learned is that when I set the 'PlugNPlay OS' BIOS-setting to 'disabled' everything worked (e.g., printer, usb-key, etc.). So, I documented my last test as:
> irqpoll nolapic All working, but PnP is off, which may be the reason.

Around this time I tried system updates, which included kernel -17, and the Busybox syndrome started.

You'll recall that I got the comptuer stable on -17 and made a backup of my menu.lst file (as I posted earlier), but then updating to -18 pooched it again, but in a slightly new way.

I got the busybox syndrome as before. So, I started a liveCD session and made a backup of my user-profile to a networked computer.

I followed my own post to get -18 working, just like I got -17 to work. But then I experienced the original instability I had when first installing Ubuntu: I had system freezing!

This didn't make sense to me. I thought the freezing problem was totally separate. Fed up, I decided to start over. I reinstalled the OS from scratch (this time AMD64)---from the liveCD (-16), and used the same temporary settings I originally used to get -16 working. I remade my user profile in the set-up process, then I overwrote the profile with my backup profile. That worked perfectly.

When the system updates appeared, it skipped -17, and it offered -18. I accepted the menu.lst file included in the update package and looked at the menu.lst file before restarting my computer.
The new menu.lst file seemed to keep my customized boot settings, so I restarted.

No more Busybox syndrome! HOWEVER, my boot settings weren't working (i.e., freezing again). So, I started testing boot-setting combinations again and found a winner.

To recap, here is the history of the kernel settings I used with some success:
-16: xforcevesa acpi=off noapic nolapic
-17: irqpoll nolapic
-18: acpi=off

By this time I learned how to check w/ kernel was running (uname -a) and I was indeed running -18 on a stable, usb-detecting system.

Today, I decided to try to update to -19. I documented what I did. Here it is:

1. check menu.lst: terminal > sudo gedit /boot/grub/menu.lst > password
2. make backup to another computer
3. install updates > password
4. menu.lst options > keep the local version currently installed
5. check menu.lst again (it kept local version intact..no updates or changes)
6. restart
7. uname -a (still running -18)

Experiment: Manual update of menu.lst
1. check menu.lst
2. copy -18 entries
3. paste -18 entires
4. edit -18 to -19
5. save/close
6. restart (stable)
7. uname -a (running -19)
8. Test HD videos (which reliably provoked freezing when using bad boot settings)

Flawless.

I'll say with confidence that my issue w/ Busybox was centered around the settings I tried in the ../boot/grub/menu.lst file.

Finally, here are some system specs
(chosen from January 2008 budget-box recommendations of arstechnica.com):

Motherboard: Asus M2A-VM HDMI
Processor: AMD Athlon 64 X2 4200+ Retail (Socket AM2)
RAM: 2GB DDR2-800 ( 2x1GB Corsair)
Sound/Network/Video: on-board
HD: Western Digital Caviar SE16 320GB SATA
Optical drive: DVD-RW/CD-RW: Samsung SH-S203B
OS: Ubuntu 8.04

How much have people been monitoring their menu.lst file?

Can you help with this problem?

Provide an answer of your own, or ask John Fino for more information if necessary.

To post a message you must log in.