How to rescue a broken system?

Asked by Michele on 2007-01-29

Hello!
I use Ubuntu 6.10 and it worked ok, since now. After a crash by Firefox, when i get on my pc, Ubuntu starts to boot, but then it stops. Even in recovery mode the story is the same.

Now, certainly i can format everything, but i wouldn't like to lose my files, that i did'nt backup.

So, how can i recovery my system?
If there isn't a way, how can i save my files?

Excuse for my not perfect english.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Michele
Solved:
2007-02-04
Last query:
2007-02-04
Last reply:
2007-02-02

You can boot from the live cd [1] and backup your files, but I don't think that a reinstallation is necessary. Are there any error messages when booting from the rescue boot option?

[1] https://wiki.ubuntu.com/LivecdRecovery

Michele (michele-dorigatti) said : #2

No. It shows various actions, writing "done." after everyone, but at a specific point, always the same, it stops.

I want to provide more information:

The last time my system worked, i launched Firefox, but... the screen vanished and i saw only a full screen terminal, with a loop series of messages. The only way i found for stop this mess, was to power off the pc. Then my system stops working.

Now, when i start it, it starts to work, i can see the ubuntu charge line, it starts to being filled, then it stops. After the screen vanishes and i can see only a flashing line, that looks like when a program wait a input. I can write, but there is no result, only my words.

Tiago Faria (gouki) said : #3

Hi Michelle,

If you're having problems on the root filesystem which is causing you problems booting, the information below will help you. I didn't ask for more information to speed up the process. In case this is what you need, fine. Otherwise, we'll work something out.

I recommend entering GRUB (press ESC during that 3 second time window - at startup) and choose Recovery Mode.

Now, in case your X starts and you have a GUI, change to a lower level (1,2,3,etc) by pressing the following key combination:

CTRL+ALT+1

Once you in here, type the following:

fsck -y

This tool will fix the erros on your HDD and the -y will answer yes to all question (there are allot of them).

Once this is done, restart your computer:

shutdown -r now

Michele (michele-dorigatti) said : #4

Hello!
I want to say to fhackenberger that his link isn't useful for my problem. But, thank you.

Tiago, I tried, but CTRL-ALT-1 doesn't work even in recovery as in normal mode.
I am a neouser, so i ask you this:

What is X?
What is a GUI?

Then, what can I do?

Bryce Harrington (bryce) said : #5

"X" is the part of Ubuntu which displays graphics on your screen like windows and buttons and things. If X breaks, then it puts you on the "console" which is the black screen with white text that you saw.

A GUI is a "Graphical User Interface". This is just jargon that means programs that have windows, buttons, scrollbars and stuff. GUI's are programs that run inside X.

Can you try this?
1. Reboot the computer, without the Live CD in it
2. Once it is stuck, now type CTRL-ALT-1. Does the screen change?
3. If you see a full screen terminal that says login, enter your username and password

If that does not work, then can you try this?
1. Get your Ubuntu Live CD, and put it in the computer's CDROM
2. Reboot the computer
3. Does it get stuck like before, or is the behavior different?

Michele (michele-dorigatti) said : #6

Hello Bryce! I had already tried what you say. I think when you speak about CTRL-ALT-1 you mean CTRL-ALT-F1. However, the firtst combination does nothing even in recovery mode. The second combination just restart the Ubuntu boot, only that this time it stops before.

The Live CD works. I have X, GUI, the normal GNOME desktop. But i can reach my ex-desktop, my files.

With others linux users' help i could get in a console, in root mode. There i can see my files, but I haven't a way to save them. In that mode i tried FSCK, as Tiago wrote. FSCK works but the system doesn't boot whatever. (to get the console, i edit the boot command adding rw init=/bin/bash)

In console mode i tried to mount floppy disk, but the command fdmount doesn't work in bash.

Can you help me to recover my normal system?
Or, if you can't, can you help me to backup my files using Live CD or any other method?

Best Michele (michele-dorigatti) said : #7

I gave up.

I prefer have a working system now. My files aren' so important. So I'll format my system.

Thank you for you help.